summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgraziano.giuliani2015-07-04 16:41:41 +0200
committergraziano.giuliani2015-07-04 16:41:41 +0200
commitdcf2552293a7cb9a07e730c97d759c3566a6f6d9 (patch)
tree802df4d004f8b585dcd51c7cf661f07d3ca57fd9
downloadaur-dcf2552293a7cb9a07e730c97d759c3566a6f6d9.tar.gz
Initial import
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD32
-rw-r--r--gmt.install22
3 files changed, 75 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a7c8b6fd8fa4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = gmt4
+ pkgdesc = Generic Mapping Tools V4: Collection of tools for manipulating geographic and Cartesian data sets, and generating EPS maps.
+ pkgver = 4.5.13
+ pkgrel = 1
+ url = http://gmt.soest.hawaii.edu/
+ install = gmt.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = gdal
+ depends = octave
+ depends = tcsh
+ depends = libxaw
+ optdepends = ghostscript
+ optdepends = gmt-coast
+ conflicts = gmt
+ source = ftp://ftp.soest.hawaii.edu/gmt/gmt-4.5.13-src.tar.bz2
+ md5sums = cc577e8c600ab0ea8e1ee7412a5902a6
+
+pkgname = gmt4
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c9e544490702
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Contributor: Benjamin Sick
+
+pkgname=gmt4
+pkgver=4.5.13
+pkgrel=1
+pkgdesc="Generic Mapping Tools V4: Collection of tools for manipulating geographic and Cartesian data sets, and generating EPS maps."
+arch=(i686 x86_64)
+url="http://gmt.soest.hawaii.edu/"
+license=('GPL')
+depends=('gdal' 'octave' 'tcsh' 'libxaw')
+optdepends=('ghostscript' 'gmt-coast')
+conflicts=('gmt')
+install=gmt.install
+source=(ftp://ftp.soest.hawaii.edu/gmt/gmt-${pkgver}-src.tar.bz2)
+md5sums=('cc577e8c600ab0ea8e1ee7412a5902a6')
+
+build() {
+ cd ${startdir}/src/gmt-${pkgver}
+ ./configure --prefix=/usr \
+ --enable-gdal --enable-octave \
+ --enable-triangle --enable-shared \
+ --enable-eps --with-gshhg-dir=/usr/share/gmt/coast
+ make || return 1
+}
+
+package() {
+ cd ${startdir}/src/gmt-${pkgver}
+ export MAKEFLAGS="-j1"
+ make DESTDIR=${pkgdir} install-all || return 1
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/gmt.install b/gmt.install
new file mode 100644
index 000000000000..e116a1726ae1
--- /dev/null
+++ b/gmt.install
@@ -0,0 +1,22 @@
+# arg 1: the new package version
+pre_install() {
+ /bin/true
+}
+
+# arg 1: the new package version
+post_install() {
+ echo "==> GMT HIGH RESOLUTION COASTLINE DATASET"
+ echo ""
+ echo "==> The default installation of GMT contains a low resolution coastline dataset."
+ echo "==> For maps at higer resolutions please install the gmt-coast package."
+}
+
+# arg 1: the new package version
+# arg 2: the old package version
+post_upgrade() {
+ post_install $1
+}
+
+op=$1
+shift
+$op $*