summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorholishing2020-02-12 05:04:10 +0800
committerholishing2020-02-12 05:04:10 +0800
commitcac8e8dee1a0b071051026a7b635bfbad16b94e6 (patch)
treec1a72fc04b92fb3860d1a8f170336044ec52f52f
parente0afd2ff60a5071e64d76d4a9e43aad4948a9cf0 (diff)
downloadaur-cac8e8dee1a0b071051026a7b635bfbad16b94e6.tar.gz
update package info, fix document installation
* remove ninja method * use doc_release man_release as document content * other miner fix or detail info correction * fix tarball path
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD38
2 files changed, 25 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6ad456577390..eb0e9dc12c57 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,25 +1,23 @@
pkgbase = gmt6
pkgdesc = Generic Mapping Tools: Tools for manipulating and plotting geographic and Cartesian data
pkgver = 6.0.0
- pkgrel = 2
+ pkgrel = 3
url = https://www.generic-mapping-tools.org
install = gmt.install
- arch = i686
arch = x86_64
license = LGPL
makedepends = cmake
- makedepends = ninja
depends = gdal
depends = fftw
depends = lapack
- depends = python-sphinx
- depends = ghostscript
+ optdepends = ghostscript
+ optdepends = python-sphinx
optdepends = gmt-coast: coastlines
optdepends = gmt-dcw: digital chart of the world polygon map
conflicts = gmt4
conflicts = gmt
- source = https://github.com/GenericMappingTools/gmt/archive/6.0.0.tar.gz
- sha256sums = 7a733e670f01d99f8fc0da51a4337320d764c06a68746621f83ccf2e3453bcb7
+ source = https://github.com/GenericMappingTools/gmt/releases/download/6.0.0/gmt-6.0.0-src.tar.xz
+ sha256sums = 8b91af18775a90968cdf369b659c289ded5b6cb2719c8c58294499ba2799b650
pkgname = gmt6
diff --git a/PKGBUILD b/PKGBUILD
index 358a8cfd578f..a38c9c986002 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,14 +4,16 @@
pkgname=gmt6
_pkgname=gmt
pkgver=6.0.0
-pkgrel=2
+pkgrel=3
pkgdesc="Generic Mapping Tools: Tools for manipulating and plotting geographic and Cartesian data"
-arch=(i686 x86_64)
+arch=(x86_64)
url="https://www.generic-mapping-tools.org"
license=('LGPL')
-makedepends=('cmake' 'ninja')
-depends=('gdal' 'fftw' 'lapack' 'python-sphinx' 'ghostscript')
+makedepends=('cmake')
+depends=('gdal' 'fftw' 'lapack')
optdepends=(
+ 'ghostscript'
+ 'python-sphinx'
'gmt-coast: coastlines'
'gmt-dcw: digital chart of the world polygon map')
conflicts=('gmt4' 'gmt')
@@ -20,17 +22,16 @@ install='gmt.install'
#source=("ftp://ftp.star.nesdis.noaa.gov/pub/sod/lsa/gmt/${_pkgname}-${pkgver}-src.tar.xz")
#source=("ftp://ftp.iris.washington.edu/pub/gmt/${_pkgname}-${pkgver}-src.tar.xz")
#source=("ftp://ftp.iag.usp.br/pub/gmt/${_pkgname}-${pkgver}-src.tar.xz")
-#source=("https://mirrors.ustc.edu.cn/gmt/${_pkgname}-${pkgver}-src.tar.xz")
-source=("https://github.com/GenericMappingTools/${_pkgname}/archive/${pkgver}.tar.gz")
-sha256sums=('7a733e670f01d99f8fc0da51a4337320d764c06a68746621f83ccf2e3453bcb7')
+source=("https://github.com/GenericMappingTools/gmt/releases/download/${pkgver}/${_pkgname}-${pkgver}-src.tar.xz")
+sha256sums=('8b91af18775a90968cdf369b659c289ded5b6cb2719c8c58294499ba2799b650')
prepare() {
cd "${srcdir}/${_pkgname}-${pkgver}"
+ rm -fr build && mkdir build
}
build() {
- mkdir -p "${srcdir}/build/aur"
- cd "${srcdir}/build/aur"
+ cd "${srcdir}/${_pkgname}-${pkgver}/build"
# -DLICENSE_RESTRICTED=off \
cmake -DCMAKE_INSTALL_PREFIX=/usr \
-DGSHHG_ROOT=/usr/share/gmt/coast \
@@ -40,18 +41,19 @@ build() {
-DGMT_MANDIR=share/man \
-DGMT_DOCDIR=share/doc/gmt \
-DCMAKE_BUILD_TYPE=Release \
- -GNinja \
- "${srcdir}/${_pkgname}-${pkgver}"
- export MAKEFLAGS="-j$(nproc)"
- ninja || return 1
+ -DGMT_OPENMP=ON \
+ ..
+ make || return 1
}
package() {
- cd "${srcdir}/build/aur"
- ninja docs_html docs_man
- cd doc/rst/man \
- && cd "${srcdir}/build/aur"
- DESTDIR="${pkgdir}" ninja install || return 1
+ cd "${srcdir}/${_pkgname}-${pkgver}/build"
+ make "DESTDIR=${pkgdir}" install || return 1
+ install -d -m 0755 ${pkgdir}/usr/share/gmt/{html,pdf}
+ install -d -m 0755 ${pkgdir}/usr/share/man/man1
+ find "${srcdir}/${_pkgname}-${pkgver}/doc_release/html" -type f -exec install -m 0755 "{}" "${pkgdir}/usr/share/gmt/html" \;
+ find "${srcdir}/${_pkgname}-${pkgver}/doc_release/pdf" -type f -exec install -m 0755 "{}" "${pkgdir}/usr/share/gmt/pdf" \;
+ find "${srcdir}/${_pkgname}-${pkgver}/man_release" -name "*.1.gz" -type f -exec install -m 0755 "{}" "${pkgdir}/usr/share/man/man1" \;
}
# vim:set ts=2 sw=2 et: