summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNick Roberts2015-07-03 12:51:13 -0400
committerNick Roberts2015-07-03 12:51:13 -0400
commit9d6d4681648c67f687c60fb6617a3ff75e8fbb2c (patch)
treeb7df01475303a56ca1fe92e754bcbc3e86321210
downloadaur-9d6d4681648c67f687c60fb6617a3ff75e8fbb2c.tar.gz
Initial import
-rw-r--r--.SRCINFO40
-rw-r--r--PKGBUILD51
2 files changed, 91 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c468ab8ca15a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,40 @@
+pkgbase = gmusicbrowser-git
+ pkgdesc = An open-source jukebox for large collections of mp3/ogg/flac files, written in perl.
+ pkgver = 1.1.14.r45.g1fe444d
+ pkgrel = 1
+ url = http://squentin.free.fr/gmusicbrowser/gmusicbrowser.html
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ makedepends = markdown
+ depends = gtk2-perl
+ optdepends = alsa-utils: enables the ALSA backend
+ optdepends = flac123: flac support for the ALSA backend
+ optdepends = mpg321: mp3 support for the ALSA backend
+ optdepends = vorbis-tools: vorbis support for the ALSA backend
+ optdepends = mplayer: enables the mplayer backend
+ optdepends = mpv: enables the mpv backend
+ optdepends = perl-glib-object-introspection: enables gstreamer-1.x backend
+ optdepends = gst-plugins-base: vorbis support
+ optdepends = gst-plugins-good: flac support
+ optdepends = gst-plugins-ugly: mp3 support
+ optdepends = perl-gstreamer: enables the gstreamer0.10 backend
+ optdepends = gstreamer0.10-base: vorbis support for the gstreamer0.10 backend
+ optdepends = gstreamer0.10-good-plugins: flac support for the gstreamer0.10 backend
+ optdepends = gstreamer0.10-ugly-plugins: mp3 support for the gstreamer0.10 backend
+ optdepends = perl-gtk2-trayicon: tray icon support
+ optdepends = perl-gtk2-mozembed: web-based plugins support
+ optdepends = perl-gtk2-webkit: alternative web-based plugin support
+ optdepends = perl-locale-gettext: localization support
+ optdepends = perl-net-dbus: control gmusicbrowser through dbus and gnome hotkeys
+ optdepends = perl-gnome2-wnck: titlebar plugin support
+ optdepends = perl-html-parser: support for accented characters in lyrics plugin
+ optdepends = perl-gtk2-notify: support for notify plugin
+ conflicts = gmusicbrowser
+ conflicts = gmusicbrowser-devel
+ source = gmusicbrowser-git::git+http://github.com/squentin/gmusicbrowser.git
+ md5sums = SKIP
+
+pkgname = gmusicbrowser-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7c8ec6c3e217
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,51 @@
+# Maintainer: RobbeR49 <robertsna@gmail.com>
+
+pkgname=gmusicbrowser-git
+pkgver=1.1.14.r45.g1fe444d
+pkgrel=1
+pkgdesc="An open-source jukebox for large collections of mp3/ogg/flac files, written in perl."
+arch=('i686' 'x86_64')
+url="http://squentin.free.fr/gmusicbrowser/gmusicbrowser.html"
+license=('GPL3')
+depends=('gtk2-perl')
+makedepends=('git' 'markdown')
+optdepends=('alsa-utils: enables the ALSA backend'
+ 'flac123: flac support for the ALSA backend'
+ 'mpg321: mp3 support for the ALSA backend'
+ 'vorbis-tools: vorbis support for the ALSA backend'
+ 'mplayer: enables the mplayer backend'
+ 'mpv: enables the mpv backend'
+ 'perl-glib-object-introspection: enables gstreamer-1.x backend'
+ 'gst-plugins-base: vorbis support'
+ 'gst-plugins-good: flac support'
+ 'gst-plugins-ugly: mp3 support'
+ 'perl-gstreamer: enables the gstreamer0.10 backend'
+ 'gstreamer0.10-base: vorbis support for the gstreamer0.10 backend'
+ 'gstreamer0.10-good-plugins: flac support for the gstreamer0.10 backend'
+ 'gstreamer0.10-ugly-plugins: mp3 support for the gstreamer0.10 backend'
+ 'perl-gtk2-trayicon: tray icon support'
+ 'perl-gtk2-mozembed: web-based plugins support'
+ 'perl-gtk2-webkit: alternative web-based plugin support'
+ 'perl-locale-gettext: localization support'
+ 'perl-net-dbus: control gmusicbrowser through dbus and gnome hotkeys'
+ 'perl-gnome2-wnck: titlebar plugin support'
+ 'perl-html-parser: support for accented characters in lyrics plugin'
+ 'perl-gtk2-notify: support for notify plugin')
+conflicts=('gmusicbrowser' 'gmusicbrowser-devel')
+source=("${pkgname}::git+http://github.com/squentin/gmusicbrowser.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ git describe --long | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "${srcdir}/${pkgname}"
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}"
+ make DESTDIR="$pkgdir" install
+}