summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristian Schwarz2015-10-30 13:46:32 +0100
committerChristian Schwarz2015-10-30 13:51:32 +0100
commit49629db5745dee4d5487ea0eaaccf65b71b3d631 (patch)
treee2e2ef80903d75f3172dbd8937ae0e97ae5657d8
downloadaur-49629db5745dee4d5487ea0eaaccf65b71b3d631.tar.gz
Initial commit.
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD34
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c1ba789f9002
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = gmux_backlight
+ pkgdesc = Modify brightness of displays attached to a gmux.
+ pkgver = 0.1
+ pkgrel = 1
+ url = https://github.com/problame/gmux_backlight
+ arch = any
+ license = BSD
+ makedepends = git
+ makedepends = asciidoc
+ source = git+https://github.com/problame/gmux_backlight#commit=ebd45a90dd6be962f310dc4517147bced792c112
+ md5sums = SKIP
+
+pkgname = gmux_backlight
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..13fba768a8d4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Christian Schwarz <me@cschwarz.com>
+pkgname=gmux_backlight
+_commit="ebd45a90dd6be962f310dc4517147bced792c112"
+pkgrel=1
+pkgdesc="Modify brightness of displays attached to a gmux."
+arch=("any")
+url="https://github.com/problame/gmux_backlight"
+license=('BSD')
+depends=()
+makedepends=('git' "asciidoc")
+source=("git+https://github.com/problame/gmux_backlight#commit=${_commit}")
+md5sums=('SKIP')
+#generate with 'makepkg -g'
+
+pkgver=0.1
+pkgver() {
+ cd "$srcdir/$pkgname"
+ git describe
+}
+
+build() {
+
+ cd "$srcdir/$pkgname"
+ make build
+ make docs
+
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+ make DESTDIR="$pkgdir/" install
+}
+
+# vim:set ts=2 sw=2 et: