summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdrian Perez de Castro2018-08-14 00:55:25 +0200
committerAdrian Perez de Castro2018-08-14 00:55:25 +0200
commit2ff936cf96b2cc4a75559a712a05432fcf2b5f61 (patch)
tree34b64b328d6be8e92f945f965d0301b17515e217
parentcebff1591fa65079d1470de4801e2a137a53afcb (diff)
downloadaur-2ff936cf96b2cc4a75559a712a05432fcf2b5f61.tar.gz
Drop unneeded hunk from gcc-support.patch
With the latest upstream patches, the dropped hunk is not only unneeded, but it also won't apply, so just remove the uneeded part of the patch.
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
-rw-r--r--gcc-support.patch17
3 files changed, 4 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 556bffe4caba..ac104bfed3c5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = gn-git
pkgdesc = Meta-build system which generates Ninja build files
- pkgver = r1448.9a9ed6df
+ pkgver = r1464.e134e493
pkgrel = 1
url = https://gn.googlesource.com/gn
arch = x86_64
@@ -15,7 +15,7 @@ pkgbase = gn-git
source = gn::git+https://gn.googlesource.com/gn
source = gcc-support.patch
sha512sums = SKIP
- sha512sums = 14f5a6236c09d1e11f6ce8984cbe1e635dc582a38ba801b719404bdaaf0b9f708262fdf13b5d6496e8af7fd50d411ab90747af1d816fa78a6a8b808ae88cb4f8
+ sha512sums = 951cc9c43040fa8341e46e44390d9db654a504b3e1cce34a013806c59a29e28ab23cdb47518e96986ec12f8aa2f995da5beb44f981cada9eb9aebe6bc7621f1a
pkgname = gn-git
diff --git a/PKGBUILD b/PKGBUILD
index eac761749a13..1c7f82d57256 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
#
pkgname=gn-git
pkgdesc='Meta-build system which generates Ninja build files'
-pkgver=r1448.9a9ed6df
+pkgver=r1464.e134e493
pkgrel=1
license=('BSD')
arch=('x86_64' 'i686')
@@ -14,7 +14,7 @@ makedepends=('python2' 'ninja' 'git')
url='https://gn.googlesource.com/gn'
source=("gn::git+${url}" gcc-support.patch)
sha512sums=('SKIP'
- '14f5a6236c09d1e11f6ce8984cbe1e635dc582a38ba801b719404bdaaf0b9f708262fdf13b5d6496e8af7fd50d411ab90747af1d816fa78a6a8b808ae88cb4f8')
+ '951cc9c43040fa8341e46e44390d9db654a504b3e1cce34a013806c59a29e28ab23cdb47518e96986ec12f8aa2f995da5beb44f981cada9eb9aebe6bc7621f1a')
pkgver () {
export GIT_DIR="${startdir}/gn"
diff --git a/gcc-support.patch b/gcc-support.patch
index e2119234a162..43db6676e29d 100644
--- a/gcc-support.patch
+++ b/gcc-support.patch
@@ -1,22 +1,5 @@
--- src/gn/build/gen.py.orig 2018-07-21 16:28:08.909054488 +0200
+++ src/gn/build/gen.py 2018-07-21 19:15:30.284412730 +0200
-@@ -293,11 +297,11 @@
- # probably resolve this and (re-)add a way to build against libc++.
- cflags.append('--sysroot=' + linux_sysroot)
- ldflags.append('--sysroot=' + linux_sysroot)
-- cflags.append('-stdlib=libstdc++')
-- ldflags.extend(['-static-libstdc++',
-- '-stdlib=libstdc++',
-- '-Wl,--as-needed',
-- ])
-+ if "clang" in cc:
-+ cflags.append('-stdlib=libstdc++')
-+ ldflags.extend(['-static-libstdc++',
-+ '-stdlib=libstdc++'])
-+ ldflags.append('-Wl,--as-needed')
- libs.extend([
- '-lgcc_s',
- '-lpthread',
@@ -308,8 +312,11 @@
ldflags.append(min_mac_version_flag)