summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIru Cai2016-01-21 10:25:52 +0800
committerIru Cai2016-01-21 10:25:52 +0800
commit617ede511d8be56fa803c605315e0b542d1960c0 (patch)
tree3323a3c145dfccd64fc1940ae91b28d54017de90
parent5affb7965e4626b459e8080d02821b502ab3f323 (diff)
downloadaur-617ede511d8be56fa803c605315e0b542d1960c0.tar.gz
build on latest boost
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD14
-rw-r--r--build_on_new_boost.patch24
3 files changed, 39 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 52f3f5a5d369..d5f035111ef8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,8 @@
+# Generated by mksrcinfo v8
+# Thu Jan 21 02:25:40 UTC 2016
pkgbase = gnash-git
pkgdesc = The GNU SWF Player based on GameSWF - git development version
- pkgver = 0.8.11.r22311.gf0f66ce
+ pkgver = 0.8.11.r22339.g62cfdfe
pkgrel = 1
url = http://www.gnu.org/software/gnash/
install = gnash.install
@@ -45,8 +47,10 @@ pkgbase = gnash-git
backup = etc/gnashpluginrc
source = git://git.sv.gnu.org/gnash.git
source = jemalloc_gnash.patch
+ source = build_on_new_boost.patch
sha256sums = SKIP
sha256sums = 422aad0cf678f8427b1601e41e6440b3526872b640b6ccd3ab93ae656a9a8c8e
+ sha256sums = 1df546e376f0a0e495f2c1a96f13e29c507dfb5f16b808696dc8c7474d833f65
pkgname = gnash-git
diff --git a/PKGBUILD b/PKGBUILD
index 160502e46337..0b2891438c1d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
pkgname=gnash-git
_gitname=gnash
-pkgver=0.8.11.r22311.gf0f66ce
+pkgver=0.8.11.r22339.g62cfdfe
pkgrel=1
pkgdesc="The GNU SWF Player based on GameSWF - git development version"
arch=('i686' 'x86_64')
@@ -24,8 +24,11 @@ options=('!emptydirs')
install=$_gitname.install
backup=('etc/gnashpluginrc')
source=('git://git.sv.gnu.org/gnash.git'
- 'jemalloc_gnash.patch')
-sha256sums=('SKIP' '422aad0cf678f8427b1601e41e6440b3526872b640b6ccd3ab93ae656a9a8c8e')
+ 'jemalloc_gnash.patch'
+ 'build_on_new_boost.patch')
+sha256sums=('SKIP'
+ '422aad0cf678f8427b1601e41e6440b3526872b640b6ccd3ab93ae656a9a8c8e'
+ '1df546e376f0a0e495f2c1a96f13e29c507dfb5f16b808696dc8c7474d833f65')
pkgver() {
cd $_gitname
@@ -45,7 +48,10 @@ build() {
patch -Np1 -i "${srcdir}/jemalloc_gnash.patch"
sed -i 's#${JEMALLOC_CONFIG} --cxxflags#${JEMALLOC_CONFIG} --cflags#g' configure
-
+
+ # https://savannah.gnu.org/bugs/?46148
+ patch -Np1 -i "${srcdir}/build_on_new_boost.patch"
+
./configure \
--prefix=/usr \
--sysconfdir=/etc \
diff --git a/build_on_new_boost.patch b/build_on_new_boost.patch
new file mode 100644
index 000000000000..6671d361e325
--- /dev/null
+++ b/build_on_new_boost.patch
@@ -0,0 +1,24 @@
+diff --git i/libbase/accumulator.h w/libbase/accumulator.h
+index 694cbd2..876c669 100644
+--- i/libbase/accumulator.h
++++ w/libbase/accumulator.h
+@@ -22,6 +22,7 @@
+
+ #include <boost/program_options/value_semantic.hpp>
+ #include <boost/any.hpp>
++#include <boost/version.hpp>
+ #include <functional>
+ #include <vector>
+ #include <string>
+@@ -61,6 +62,11 @@ public:
+ virtual unsigned min_tokens() const { return 0; }
+ virtual unsigned max_tokens() const { return 0; }
+
++#if BOOST_VERSION >= 105900
++ /// There are no tokens, so this is indifferent.
++ virtual bool adjacent_tokens_only() const { return false; }
++#endif
++
+ /// Accumulating from different sources is silly.
+ virtual bool is_composing() const { return false; }
+