summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIru Cai2015-09-26 17:16:10 +0800
committerIru Cai2015-09-26 17:16:10 +0800
commit8ea2506cf628f733720cfe2863d07acae06049c0 (patch)
tree7e5980304e45b6c0baf72a3fa72fabd1a98547ee
parent94a1ff77af2a980abc1ea71deab8ee8f145f72b5 (diff)
downloadaur-8ea2506cf628f733720cfe2863d07acae06049c0.tar.gz
fix build issue on gnash_jemalloc
-rw-r--r--PKGBUILD10
-rw-r--r--jemalloc_gnash.patch13
2 files changed, 20 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b1decabe5af0..160502e46337 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
pkgname=gnash-git
_gitname=gnash
-pkgver=0.8.11.r22277.g6b269f9
+pkgver=0.8.11.r22311.gf0f66ce
pkgrel=1
pkgdesc="The GNU SWF Player based on GameSWF - git development version"
arch=('i686' 'x86_64')
@@ -23,8 +23,9 @@ replaces=('gnash-common' 'gnash-gtk' 'gnash')
options=('!emptydirs')
install=$_gitname.install
backup=('etc/gnashpluginrc')
-source=('git://git.sv.gnu.org/gnash.git')
-sha256sums=('SKIP')
+source=('git://git.sv.gnu.org/gnash.git'
+ 'jemalloc_gnash.patch')
+sha256sums=('SKIP' '422aad0cf678f8427b1601e41e6440b3526872b640b6ccd3ab93ae656a9a8c8e')
pkgver() {
cd $_gitname
@@ -42,6 +43,9 @@ prepare() {
build() {
cd $_gitname
+ patch -Np1 -i "${srcdir}/jemalloc_gnash.patch"
+ sed -i 's#${JEMALLOC_CONFIG} --cxxflags#${JEMALLOC_CONFIG} --cflags#g' configure
+
./configure \
--prefix=/usr \
--sysconfdir=/etc \
diff --git a/jemalloc_gnash.patch b/jemalloc_gnash.patch
new file mode 100644
index 000000000000..743507069f8b
--- /dev/null
+++ b/jemalloc_gnash.patch
@@ -0,0 +1,13 @@
+diff --git a/libbase/jemalloc_gnash.c b/libbase/jemalloc_gnash.c
+index a702688..7bfd752 100644
+--- a/libbase/jemalloc_gnash.c
++++ b/libbase/jemalloc_gnash.c
+@@ -18,7 +18,7 @@
+ */
+
+ #include <stddef.h>
+-#include <jemalloc.h>
++#include <jemalloc/jemalloc.h>
+
+ #ifdef HAVE_CONFIG_H
+ # include "gnashconfig.h"