summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRod Kay2022-10-01 00:59:23 +1000
committerRod Kay2022-10-01 00:59:23 +1000
commit845e2ce1cf459f80f7c62e45d30bbfee5061c341 (patch)
tree2a305481c4136c440e03e7af1e3ae5b6f1fba27a
parentd83be90969b27d533eb1039a36343a96a125e79e (diff)
downloadaur-845e2ce1cf459f80f7c62e45d30bbfee5061c341.tar.gz
Rid python2.
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD22
2 files changed, 16 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a0e42b8f586a..018d1ad30c79 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -11,14 +11,13 @@ pkgbase = gnat-gps
makedepends = graphviz
depends = clang
depends = ada_language_server
- depends = gnatcoll-python2
+ depends = gnatcoll-python
depends = gnatcoll-xref
depends = gnatcoll-db2ada
depends = gtkada
- depends = python2-gobject
- depends = python2-gobject2
- depends = python2-cairo
- depends = python2-yaml
+ depends = python-gobject
+ depends = python-cairo
+ depends = python-yaml
source = https://github.com/AdaCore/gnatstudio/archive/refs/heads/22.2.zip
source = gnatstudio-support.zip::https://github.com/charlie5/archlinux-gnatstudio-support/archive/refs/heads/main.zip
source = 0003-Honour-DESTDIR-in-installation-targets.patch
diff --git a/PKGBUILD b/PKGBUILD
index 7616e15c1acd..956202fbc82b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,9 +12,10 @@ arch=('i686' 'x86_64')
url="https://github.com/AdaCore/gps"
license=('GPL')
-depends=("clang" "ada_language_server"
- "gnatcoll-python2" "gnatcoll-xref" "gnatcoll-db2ada" "gtkada"
- "python2-gobject" "python2-gobject2" "python2-cairo" "python2-yaml")
+depends=("clang" "ada_language_server"
+ "gnatcoll-python" "gnatcoll-xref" "gnatcoll-db2ada" "gtkada"
+ "python-gobject" "python-cairo" "python-yaml")
+# "python-gobject" "python-gobject2" "python-cairo" "python-yaml")
makedepends=('gprbuild' 'texlive-latexextra' 'graphviz')
@@ -63,7 +64,8 @@ build()
# https://gcc.gnu.org/onlinedocs/gcc-10.2.0/gnat_ugn/Optimization-and-Strict-Aliasing.html
export BUILD=Production
- make -j1 OS=unix PROCESSORS=0 BUILD=Production PRJ_BUILD=Release LIBRARY_TYPE=relocatable GPRBUILD_FLAGS="-R -cargs $ADA_FLAGS -fno-strict-aliasing -largs $LDFLAGS -lpython2.7 -lpython3.10 -gargs"
+ make -j1 OS=unix PROCESSORS=0 BUILD=Production PRJ_BUILD=Release LIBRARY_TYPE=relocatable GPRBUILD_FLAGS="-R -cargs $ADA_FLAGS -fno-strict-aliasing -largs $LDFLAGS -lpython3.10 -gargs"
+# make -j1 OS=unix PROCESSORS=0 BUILD=Production PRJ_BUILD=Release LIBRARY_TYPE=relocatable GPRBUILD_FLAGS="-R -cargs $ADA_FLAGS -fno-strict-aliasing -largs $LDFLAGS -lpython2.7 -lpython3.10 -gargs"
# make -C docs all ### Docs are currently broken.
}
@@ -86,13 +88,13 @@ package()
# Add no longer available Python 2.7 packages.
#
- mkdir -p "$pkgdir/usr/lib/python2.7/site-packages"
+# mkdir -p "$pkgdir/usr/lib/python2.7/site-packages"
- pushd "$srcdir/site-packages"
- for file in $(find . -type f); do
- install -m 644 -D ${file} "$pkgdir/usr/lib/python2.7/site-packages"/${file#source/}
- done
- popd
+# pushd "$srcdir/site-packages"
+# for file in $(find . -type f); do
+# install -m 644 -D ${file} "$pkgdir/usr/lib/python2.7/site-packages"/${file#source/}
+# done
+# popd
# Add the desktop config.
install -Dm644 -t "$pkgdir/usr/share/applications/" "$srcdir/gps.desktop"