summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRod Kay2016-06-05 12:37:33 +1000
committerRod Kay2016-06-05 12:37:33 +1000
commit7c1a85321ec76ce5654530e4c4723d872c762451 (patch)
tree1c0f352b1e67d8314543ea9224c266da59d80cff
parent85094fc911512186a1a921d547451831c5ceb0dd (diff)
downloadaur-7c1a85321ec76ce5654530e4c4723d872c762451.tar.gz
Update to 2016 version.
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD43
-rw-r--r--patch-Makefile19
-rw-r--r--patch-gnatcoll-scripts.adb44
-rw-r--r--patch-gnatcoll-scripts.ads38
-rw-r--r--patch-gnatcoll_full.gpr31
6 files changed, 176 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b0aac54ee472..2d437da89158 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,8 @@
+# Generated by mksrcinfo v8
+# Sun Jun 5 02:37:07 UTC 2016
pkgbase = gnatcoll
pkgdesc = Provides components to complement the Ada & GNAT libraries (string/text, memory management, file handling, etc).
- pkgver = gpl2015
+ pkgver = gpl2016
pkgrel = 1
url = http://libre.adacore.com/tools/gnat-component-collection
arch = i686
@@ -16,10 +18,16 @@ pkgbase = gnatcoll
depends = python2-pep8
depends = python2-jedi
depends = python2-gobject
- source = http://mirrors.cdn.adacore.com/art/564b3e2ec8e196b040fbd140
- source = patch-python_support_gtk.c
- md5sums = bc70aaf2e21a488a00f87fdec112454a
- md5sums = 59ceebb56df53b2b35f97ff3f0df5df4
+ source = http://mirrors.cdn.adacore.com/art/5739942ac7a447658d00e1e7
+ source = patch-gnatcoll_full.gpr
+ source = patch-Makefile
+ source = patch-gnatcoll-scripts.ads
+ source = patch-gnatcoll-scripts.adb
+ sha1sums = 921c17e7dcb2cc00e4fe0f58d34896ed1d11fc5e
+ sha1sums = d9b99596d69800aa5ad0d107a456195e1fdd7bc2
+ sha1sums = 80d6204a1ac0040f867184dfea75cc2988ba05da
+ sha1sums = bcb378d479bf88343e2c6ec8beb599287c0f7139
+ sha1sums = 3f58009f5d7188addc50e65ae5fb18b07f03f52c
pkgname = gnatcoll
diff --git a/PKGBUILD b/PKGBUILD
index f5a66804ca50..091c7c247f1a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Contributor: Rod Kay <charlie5 on #ada at freenode.net>
pkgname=gnatcoll
-pkgver=gpl2015
+pkgver=gpl2016
pkgrel=1
pkgdesc="Provides components to complement the Ada & GNAT libraries (string/text, memory management, file handling, etc)."
@@ -12,18 +12,27 @@ license=('GPL')
depends=("gcc-ada" "xmlada" "gtkada" "gprbuild" "gnat_util" "python2" "python2-pep8" "python2-jedi" "python2-gobject")
makedepends=("nawk")
-source=(http://mirrors.cdn.adacore.com/art/564b3e2ec8e196b040fbd140
- patch-python_support_gtk.c)
-
-md5sums=('bc70aaf2e21a488a00f87fdec112454a'
- '59ceebb56df53b2b35f97ff3f0df5df4')
+source=(http://mirrors.cdn.adacore.com/art/5739942ac7a447658d00e1e7
+ patch-gnatcoll_full.gpr
+ patch-Makefile
+ patch-gnatcoll-scripts.ads
+ patch-gnatcoll-scripts.adb)
+sha1sums=('921c17e7dcb2cc00e4fe0f58d34896ed1d11fc5e'
+ 'd9b99596d69800aa5ad0d107a456195e1fdd7bc2'
+ '80d6204a1ac0040f867184dfea75cc2988ba05da'
+ 'bcb378d479bf88343e2c6ec8beb599287c0f7139'
+ '3f58009f5d7188addc50e65ae5fb18b07f03f52c')
prepare()
{
- cd $srcdir/gnatcoll-gpl-2015-src
- patch -p0 -i ../patch-python_support_gtk.c
+ cd $srcdir/gnatcoll-gpl-2016-src
+
+ patch -p0 -i ../patch-gnatcoll_full.gpr
+ patch -p0 -i ../patch-Makefile
+ patch -p0 -i ../patch-gnatcoll-scripts.ads
+ patch -p0 -i ../patch-gnatcoll-scripts.adb
}
@@ -33,7 +42,7 @@ build()
export OS=unix
export Build=Production
- cd $srcdir/gnatcoll-gpl-2015-src
+ cd $srcdir/gnatcoll-gpl-2016-src
## Force use of python2.
#
@@ -43,16 +52,20 @@ build()
ln -s /usr/bin/python2-config $srcdir/temp_bin/python-config
export PATH=$srcdir/temp_bin:$PATH
- AWK=/usr/bin/nawk ./configure --prefix=/usr
+ AWK=/usr/bin/nawk ./configure --prefix=/usr --disable-shared
ADA_PROJECT_PATH=/usr/lib/gnat make PROCESSORS=3
+
+ ls obj -alh
+ cp src/obj/gnatcoll_db2ada .
+ cp src/obj/gnatinspect .
}
package()
{
- cd $srcdir/gnatcoll-gpl-2015-src
+ cd $srcdir/gnatcoll-gpl-2016-src
## Force use of python2.
#
@@ -62,5 +75,11 @@ package()
ln -s /usr/bin/python2-config $srcdir/temp_bin/python-config
export PATH=$srcdir/temp_bin:$PATH
- make DESTDIR="$pkgdir/" install
+ make DESTDIR="$pkgdir/" prefix=$pkgdir/usr install
+
+ cp src/dborm.py $pkgdir/usr/share/gnatcoll
+
+ mkdir -p $pkgdir/usr/bin
+ cp gnatcoll_db2ada $pkgdir/usr/bin
+ cp gnatinspect $pkgdir/usr/bin
}
diff --git a/patch-Makefile b/patch-Makefile
new file mode 100644
index 000000000000..c3c9f4ecb91e
--- /dev/null
+++ b/patch-Makefile
@@ -0,0 +1,19 @@
+*** Makefile 2016-06-04 10:59:52.438996452 +1000
+--- Makefile-new 2016-06-04 11:00:02.238996854 +1000
+***************
+*** 68,74 ****
+ ifeq (${WITH_GTK},yes)
+ ${GPRINSTALL} ${GPRINST_OPTS} -Psrc/gnatcoll_gtk
+ endif
+! ${GPRINSTALL} --mode=usage ${GPRINST_OPTS} -Psrc/gnatcoll_tools
+
+ install_gps_plugin: force
+ mkdir -p $(prefix)/share/gps/plug-ins
+--- 68,74 ----
+ ifeq (${WITH_GTK},yes)
+ ${GPRINSTALL} ${GPRINST_OPTS} -Psrc/gnatcoll_gtk
+ endif
+! # ${GPRINSTALL} --mode=usage ${GPRINST_OPTS} -Psrc/gnatcoll_tools
+
+ install_gps_plugin: force
+ mkdir -p $(prefix)/share/gps/plug-ins
diff --git a/patch-gnatcoll-scripts.adb b/patch-gnatcoll-scripts.adb
new file mode 100644
index 000000000000..f8609522d555
--- /dev/null
+++ b/patch-gnatcoll-scripts.adb
@@ -0,0 +1,44 @@
+--- src/gnatcoll-scripts.adb
++++ src/gnatcoll-scripts.adb
+@@ -209,6 +209,40 @@
+ Unchecked_Free (List.List);
+ end Free;
+
++
++ -------------------
++ -- Get_Instances --
++ -------------------
++
++ function Get_Instances (List : Instance_List) return Instance_Array is
++ Null_List : Instance_Array (1 .. 0);
++ begin
++ if List.List = null then
++ return Null_List;
++ else
++ return List.List.all;
++ end if;
++ end Get_Instances;
++
++ ------------
++ -- Length --
++ ------------
++
++ function Length (List : Instance_List_Access) return Natural is
++-- use GNATCOLL.RefCount;
++ Count : Natural := 0;
++ begin
++ if List /= null and then List.List /= null then
++ for L in List.List'Range loop
++-- if List.List (L).Initialized then
++ if List.List (L).Ref /= Null_Ref then
++ Count := Count + 1;
++ end if;
++ end loop;
++ end if;
++ return Count;
++ end Length;
++
+ ---------
+ -- Get --
+ ---------
+
diff --git a/patch-gnatcoll-scripts.ads b/patch-gnatcoll-scripts.ads
new file mode 100644
index 000000000000..309c4d8a6ffb
--- /dev/null
+++ b/patch-gnatcoll-scripts.ads
@@ -0,0 +1,38 @@
+--- src/gnatcoll-scripts.ads
++++ src/gnatcoll-scripts.ads
+@@ -766,6 +766,12 @@
+ -- Stores the instance created for some GPS internal data, so that the same
+ -- script instance is reused every time we reference the same Ada object.
+
++ type Instance_List_Access is access all Instance_list;
++
++ type Instance_Array is array (Natural range <>) of Class_Instance;
++ type Instance_Array_Access is access Instance_Array;
++
++
+ type Inst_Cursor is private;
+ function First (Self : Instance_List) return Inst_Cursor;
+ procedure Next (Self : Instance_List; Pos : in out Inst_Cursor);
+@@ -777,6 +783,12 @@
+
+ procedure Free (List : in out Instance_List);
+ -- Free the instances stored in the list
++
++ function Get_Instances (List : Instance_List) return Instance_Array;
++ -- Return the instance array contained in the given list
++
++ function Length (List : Instance_List_Access) return Natural;
++ -- Return the number of instances that are stored in the list
+
+ function Get
+ (List : Instance_List;
+@@ -1575,8 +1587,6 @@
+ Console : Virtual_Console;
+ end record;
+
+- type Instance_Array is array (Natural range <>) of Class_Instance;
+- type Instance_Array_Access is access Instance_Array;
+ type Instance_List is record
+ List : Instance_Array_Access;
+ -- instances are stored in no particular order. As soon as a
+
diff --git a/patch-gnatcoll_full.gpr b/patch-gnatcoll_full.gpr
new file mode 100644
index 000000000000..020370e6db20
--- /dev/null
+++ b/patch-gnatcoll_full.gpr
@@ -0,0 +1,31 @@
+*** gnatcoll_full.gpr 2016-06-04 09:32:41.495448462 +1000
+--- gnatcoll_full.gpr-new 2016-06-04 09:32:58.362115820 +1000
+***************
+*** 61,73 ****
+ package Builder renames GNATCOLL_Shared.Builder;
+
+ package Install is
+! for Artifacts ("share/examples/gnatcoll") use ("examples/*");
+! for Artifacts ("share/doc/gnatcoll/html") use ("docs/_build/html");
+! for Artifacts ("share/doc/gnatcoll")
+! use ("docs/_build/latex/GNATColl.pdf");
+! for Artifacts ("share/gps/support/core/gnatcoll")
+! use ("distrib/gnatcoll/*py");
+! for Artifacts ("share/gnatcoll") use ("src/dborm.py");
+ end Install;
+
+ end Gnatcoll_Full;
+--- 61,73 ----
+ package Builder renames GNATCOLL_Shared.Builder;
+
+ package Install is
+! -- for Artifacts ("share/examples/gnatcoll") use ("examples/*");
+! -- for Artifacts ("share/doc/gnatcoll/html") use ("docs/_build/html");
+! -- for Artifacts ("share/doc/gnatcoll")
+! -- use ("docs/_build/latex/GNATColl.pdf");
+! -- for Artifacts ("share/gps/support/core/gnatcoll")
+! -- use ("distrib/gnatcoll/*py");
+! -- for Artifacts ("share/gnatcoll") use ("src/dborm.py");
+ end Install;
+
+ end Gnatcoll_Full;