summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRod Kay2017-06-05 17:07:10 +1000
committerRod Kay2017-06-05 17:07:10 +1000
commitbac59624f354fb7a001591d6be66a88ceac983e8 (patch)
treede83d6d7bffeb39d1a35a2666746f6e6235b2780
parent160895ed01a011676eac9efa027daf7ff8880247 (diff)
downloadaur-bac59624f354fb7a001591d6be66a88ceac983e8.tar.gz
Fixes
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD15
2 files changed, 14 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4a576d476e82..4330cc64d209 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Mon Jun 5 07:01:51 UTC 2017
+# Mon Jun 5 07:06:56 UTC 2017
pkgbase = gnatcoll
pkgdesc = gnat components collection
pkgver = 17.1.r64.g09ee8996
diff --git a/PKGBUILD b/PKGBUILD
index 317434e105a1..700bdde32542 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -26,23 +26,33 @@ sha1sums=('SKIP'
'7dec45682d4a1c44e9517ecb9c4e2f5afccd08c2'
'04799236d75963c9abe2d41c9f2a6c3d3e61780d')
+
pkgver() {
cd gnatcoll
git describe --long --tags | sed 's/^gnatcoll-//; s/-/.r/; s/-/./'
}
+
prepare() {
cd gnatcoll
patch -Np1 -i "$srcdir"/use_fpic_for_shared.patch
patch -Np1 -i "$srcdir"/use_fpic_for_gtk.patch
patch -Np1 -i "$srcdir"/use_fpic_for_python.patch
patch -Np1 -i "$srcdir"/expose-cargs-and-largs-makefile.patch
+
+ ## Force use of pyhon2
+ #
+ rm -fr temp_bin
+ mkdir temp_bin
+ ln -s /usr/bin/python2 temp_bin/python
+ ln -s /usr/bin/python2-config temp_bin/python-config
}
+
build() {
cd gnatcoll
- export PYTHON=python2
+ export PATH=$srcdir/$pkgname/temp_bin:$PATH
export OS=unix
./configure --prefix=/usr \
@@ -52,7 +62,8 @@ build() {
make PROCESSORS="$(nproc)" GPRBUILD_OPTIONS=-R
}
+
package() {
cd gnatcoll
- PYTHON=python2 make prefix="$pkgdir"/usr install
+ make prefix="$pkgdir"/usr install
}