summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRod Kay2021-06-21 13:54:17 +1000
committerRod Kay2021-06-21 13:54:17 +1000
commit7526a0fdf086c3284849d3797179045595db75b6 (patch)
tree98f9f5fd41b64431fac82a05fd24380770db4a25
parent869f8480fd5523f58d16c951bda807e9c147cc3d (diff)
downloadaur-7526a0fdf086c3284849d3797179045595db75b6.tar.gz
Install licenses.
-rw-r--r--PKGBUILD13
1 files changed, 12 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 20eeb2e80719..80a9306db5c3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@ pkgrel=2
pkgdesc='Gnat components collection - Core packages.'
url='https://github.com/AdaCore/gnatcoll-core/'
arch=('i686' 'x86_64')
-license=('GPL')
+license=('GPL3' 'custom')
depends=('libgpr')
makedepends=('gprbuild')
@@ -35,4 +35,15 @@ package()
# Make one install at a time to avoid GPRinstall reading/writing to
# the same installed project files at the same time.
make prefix="$pkgdir/usr" install -j1
+
+ # Install the license.
+ install -D -m644 \
+ "COPYING3" \
+ "$pkgdir/usr/share/licenses/$pkgname/COPYING3"
+
+ # Install the custom license.
+ install -D -m644 \
+ "COPYING.RUNTIME" \
+ "$pkgdir/usr/share/licenses/$pkgname/COPYING.RUNTIME"
+
}