summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRod Kay2021-06-21 15:08:28 +1000
committerRod Kay2021-06-21 15:08:28 +1000
commitf95fad8f081ded63dbe7490192b0f76b0a77d258 (patch)
tree20067a5045315391f3301d59724a763473424edd
parent5d71e3a4cd55658d91ef3d2bb794432ff386ab31 (diff)
downloadaur-f95fad8f081ded63dbe7490192b0f76b0a77d258.tar.gz
Add licenses.
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD14
2 files changed, 15 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e78497d2d698..1b4cd4e1eac0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,13 @@
pkgbase = gnatcoll-db2ada
pkgdesc = GNAT Components Collection - Tool to generate Ada code from database schemas
pkgver = 21.0.0
- pkgrel = 2
+ pkgrel = 3
epoch = 1
url = https://github.com/AdaCore/gnatcoll-db/
arch = i686
arch = x86_64
- license = GPL
+ license = GPL3
+ license = custom
makedepends = gprbuild
depends = gnatcoll-core
depends = gnatcoll-sql
@@ -15,4 +16,3 @@ pkgbase = gnatcoll-db2ada
sha256sums = 380abb79f49510b2bea461fbe3af1966cf82c3ad738791bcb870dc575583a136
pkgname = gnatcoll-db2ada
-
diff --git a/PKGBUILD b/PKGBUILD
index c8f4e45263e1..61aa3dbfee54 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,13 +4,13 @@
pkgname=gnatcoll-db2ada
epoch=1
pkgver=21.0.0
-pkgrel=2
+pkgrel=3
_repo_name=gnatcoll-db
pkgdesc='GNAT Components Collection - Tool to generate Ada code from database schemas'
url='https://github.com/AdaCore/gnatcoll-db/'
arch=('i686' 'x86_64')
-license=('GPL')
+license=('GPL3' 'custom')
depends=('gnatcoll-core' 'gnatcoll-sql' 'python')
makedepends=('gprbuild')
@@ -33,4 +33,14 @@ package()
# Make one install at a time to avoid GPRinstall reading/writing to
# the same installed project files at the same time.
make prefix="$pkgdir/usr" install -j1
+
+ # Install the license.
+ install -D -m644 \
+ "../COPYING3" \
+ "$pkgdir/usr/share/licenses/$pkgname/COPYING3"
+
+ # Install the custom license.
+ install -D -m644 \
+ "../COPYING.RUNTIME" \
+ "$pkgdir/usr/share/licenses/$pkgname/COPYING.RUNTIME"
}