summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRod Kay2021-06-21 16:10:34 +1000
committerRod Kay2021-06-21 16:10:34 +1000
commitb91bb0a389c171492386fb00259407584b73b05b (patch)
tree3bd96030dd64bc3a4ae9892f0a07c9e51044f074
parent447e6b70af26e8733b0176eab14e78dd7ff5db89 (diff)
downloadaur-b91bb0a389c171492386fb00259407584b73b05b.tar.gz
Install licenses.
-rw-r--r--PKGBUILD12
1 files changed, 11 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index daf5419911b2..37f0932d78c6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,7 +10,7 @@ _repo_name=gnatcoll-db
pkgdesc='GNAT Components Collection - the gnatinspect tool.'
url='https://github.com/AdaCore/gnatcoll-db/'
arch=('i686' 'x86_64')
-license=('GPL')
+license=('GPL3' 'custom')
depends=('gnatcoll-core' 'gnatcoll-readline' 'gnatcoll-xref')
makedepends=('gprbuild')
@@ -33,4 +33,14 @@ package()
# Make one install at a time to avoid GPRinstall reading/writing to
# the same installed project files at the same time.
make prefix="$pkgdir/usr" install -j1
+
+ # Install the license.
+ install -D -m644 \
+ "../COPYING3" \
+ "$pkgdir/usr/share/licenses/$pkgname/COPYING3"
+
+ # Install the custom license.
+ install -D -m644 \
+ "../COPYING.RUNTIME" \
+ "$pkgdir/usr/share/licenses/$pkgname/COPYING.RUNTIME"
}