summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRod Kay2018-09-07 13:36:55 +1000
committerRod Kay2018-09-07 13:36:55 +1000
commit5ee62727f0181524121ec4f0cbf29e60ac912197 (patch)
treebd36962aa4505f0091577f72645d2f495b81fa81
downloadaur-5ee62727f0181524121ec4f0cbf29e60ac912197.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD34
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..968e9008babe
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = gnatcoll-iconv
+ pkgdesc = GNAT Components Collection - Bindings to Libiconv
+ pkgver = 2018
+ pkgrel = 1
+ url = https://github.com/AdaCore/gnatcoll-bindings/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = gprbuild
+ depends = gcc-ada
+ depends = libiconv
+ depends = gnatcoll-core
+ provides = gnatcoll-iconv
+ conflicts = gnatcoll-iconv
+ source = http://mirrors.cdn.adacore.com/art/5b0ce9cfc7a4475261f97ca5
+ sha1sums = 42682c885e4a02bb03786aa9ece3a4214ca419f8
+
+pkgname = gnatcoll-iconv
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f749449853d4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Rod Kay <charlie5 on #ada at freenode.net>
+# Contributor: Pierre-Marie de Rodat <pmderodat on #ada at freenode.net>
+
+pkgname=gnatcoll-iconv
+pkgver=2018
+pkgrel=1
+
+pkgdesc='GNAT Components Collection - Bindings to Libiconv'
+url='https://github.com/AdaCore/gnatcoll-bindings/'
+arch=('i686' 'x86_64')
+license=('GPL')
+
+depends=('gcc-ada' 'libiconv' 'gnatcoll-core')
+makedepends=('gprbuild')
+
+provides=('gnatcoll-iconv')
+conflicts=('gnatcoll-iconv')
+
+source=('http://mirrors.cdn.adacore.com/art/5b0ce9cfc7a4475261f97ca5')
+sha1sums=('42682c885e4a02bb03786aa9ece3a4214ca419f8')
+
+
+build()
+{
+ cd "$srcdir/gnatcoll-bindings-gpl-2018-src/iconv"
+ python2 setup.py build -j$(nproc) --prefix=/usr -R
+}
+
+package()
+{
+ cd "$srcdir/gnatcoll-bindings-gpl-2018-src/iconv"
+
+ python2 setup.py install --prefix="$pkgdir/usr"
+}