summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRod Kay2018-09-07 13:46:51 +1000
committerRod Kay2018-09-07 13:46:51 +1000
commitfc2ad3c3998a9b51800e0ffd5f1a8bc2eff07531 (patch)
treede3c852c846d227a8556dadff401987f6154dd64
downloadaur-fc2ad3c3998a9b51800e0ffd5f1a8bc2eff07531.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD37
2 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..754272d8330b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = gnatcoll-postgres
+ pkgdesc = GNAT Components Collection - Postgres database support
+ pkgver = 2018
+ pkgrel = 1
+ url = https://github.com/AdaCore/gnatcoll-db/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = gprbuild
+ depends = gcc-ada
+ depends = gnatcoll-core
+ depends = postgresql
+ provides = gnatcoll-postgres
+ conflicts = gnatcoll-postgres
+ source = http://mirrors.cdn.adacore.com/art/5b0ce9cbc7a4475263382be6
+ sha1sums = 85c90002bb506e3e72e38d2e6604734402d23a32
+
+pkgname = gnatcoll-postgres
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5b03a35233cc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Rod Kay <charlie5 on #ada at freenode.net>
+
+pkgname=gnatcoll-postgres
+pkgver=2018
+pkgrel=1
+
+pkgdesc='GNAT Components Collection - Postgres database support'
+url='https://github.com/AdaCore/gnatcoll-db/'
+arch=('i686' 'x86_64')
+license=('GPL')
+
+depends=('gcc-ada' 'gnatcoll-core' 'postgresql')
+makedepends=('gprbuild')
+
+provides=('gnatcoll-postgres')
+conflicts=('gnatcoll-postgres')
+
+source=('http://mirrors.cdn.adacore.com/art/5b0ce9cbc7a4475263382be6')
+sha1sums=('85c90002bb506e3e72e38d2e6604734402d23a32')
+
+
+build()
+{
+ cd "$srcdir/gnatcoll-db-gpl-2018-src/postgres"
+
+ make setup BUILD=PROD prefix=/usr
+ make PROCESSORS="$(nproc)" GPRBUILD_OPTIONS=-R
+}
+
+package()
+{
+ cd "$srcdir/gnatcoll-db-gpl-2018-src/postgres"
+
+ # Make one install at a time to avoid GPRinstall reading/writing to
+ # the same installed project files at the same time.
+ make prefix="$pkgdir/usr" install -j1
+}