summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRod Kay2021-06-21 15:32:53 +1000
committerRod Kay2021-06-21 15:32:53 +1000
commit6092f9ce16661e593d3dbd386c091af6396306e9 (patch)
tree75bae4b8fd84815b1e2bd300b2bf7f5ce0e62cac
parent4d151442866ca500eebc11203c34a1ceb48007d8 (diff)
downloadaur-6092f9ce16661e593d3dbd386c091af6396306e9.tar.gz
Install licenses.
-rw-r--r--PKGBUILD12
1 files changed, 11 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5d2bc335e441..737df8d8d9c6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,7 +10,7 @@ _repo_name=gnatcoll-db
pkgdesc='GNAT Components Collection - SQLite database support'
url='https://github.com/AdaCore/gnatcoll-db/'
arch=('i686' 'x86_64')
-license=('GPL')
+license=('GPL3' 'custom')
depends=('gnatcoll-core' 'gnatcoll-sql')
makedepends=('gprbuild')
@@ -33,4 +33,14 @@ package()
# Make one install at a time to avoid GPRinstall reading/writing to
# the same installed project files at the same time.
make prefix="$pkgdir/usr" install -j1
+
+ # Install the license.
+ install -D -m644 \
+ "../COPYING3" \
+ "$pkgdir/usr/share/licenses/$pkgname/COPYING3"
+
+ # Install the custom license.
+ install -D -m644 \
+ "../COPYING.RUNTIME" \
+ "$pkgdir/usr/share/licenses/$pkgname/COPYING.RUNTIME"
}