summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRod Kay2018-09-07 13:50:09 +1000
committerRod Kay2018-09-07 13:50:09 +1000
commit0ee3579f7ffaa720807ec6cb7882852caaf9fb60 (patch)
tree89877601725321e5fb4ed8a1fea93b17f959f781
downloadaur-0ee3579f7ffaa720807ec6cb7882852caaf9fb60.tar.gz
Initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD37
2 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a1dd5b72e008
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = gnatcoll-xref
+ pkgdesc = GNAT Components Collection - Tool to support parsing *.ali and *.gli files.
+ pkgver = 2018
+ pkgrel = 1
+ url = https://github.com/AdaCore/gnatcoll-db/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = gprbuild
+ depends = gcc-ada
+ depends = gnatcoll-core
+ depends = gnatcoll-iconv
+ depends = gnatcoll-sqlite
+ provides = gnatcoll-xref
+ conflicts = gnatcoll-xref
+ source = http://mirrors.cdn.adacore.com/art/5b0ce9cbc7a4475263382be6
+ sha1sums = 85c90002bb506e3e72e38d2e6604734402d23a32
+
+pkgname = gnatcoll-xref
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..834526d3eb63
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Rod Kay <charlie5 on #ada at freenode.net>
+
+pkgname=gnatcoll-xref
+pkgver=2018
+pkgrel=1
+
+pkgdesc='GNAT Components Collection - Tool to support parsing *.ali and *.gli files.'
+url='https://github.com/AdaCore/gnatcoll-db/'
+arch=('i686' 'x86_64')
+license=('GPL')
+
+depends=('gcc-ada' 'gnatcoll-core' 'gnatcoll-iconv' 'gnatcoll-sqlite')
+makedepends=('gprbuild')
+
+provides=('gnatcoll-xref')
+conflicts=('gnatcoll-xref')
+
+source=('http://mirrors.cdn.adacore.com/art/5b0ce9cbc7a4475263382be6')
+sha1sums=('85c90002bb506e3e72e38d2e6604734402d23a32')
+
+
+build()
+{
+ cd "$srcdir/gnatcoll-db-gpl-2018-src/xref"
+
+ make setup BUILD=PROD prefix=/usr
+ make PROCESSORS="$(nproc)" GPRBUILD_OPTIONS=-R
+}
+
+package()
+{
+ cd "$srcdir/gnatcoll-db-gpl-2018-src/xref"
+
+ # Make one install at a time to avoid GPRinstall reading/writing to
+ # the same installed project files at the same time.
+ make prefix="$pkgdir/usr" install -j1
+}