summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKrzysztof (3ED) AS2015-07-02 10:03:49 +0200
committerKrzysztof (3ED) AS2015-07-02 10:03:49 +0200
commitdfb9170ab8eafaec11d6590f1eaea7a95f4dfdc1 (patch)
tree6dcc0774a30320312f6c10ee26c3e47afc778293
downloadaur-gnaughty.tar.gz
moving files, making space for additional scripts, aur4 and other stuff
-rw-r--r--.SRCINFO22
-rw-r--r--10-curl-remove_deprecated_header.patch10
-rw-r--r--20-fix_links_parser.patch45
-rw-r--r--PKGBUILD38
4 files changed, 115 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..333902c04aa9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = gnaughty
+ pkgdesc = A program to automatically download adult content from internet directories (gtk2)
+ pkgver = 1.2.5
+ pkgrel = 3
+ url = http://gnaughty.sourceforge.net/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = make
+ makedepends = pkgconfig>=0.9
+ depends = gconf>=2
+ depends = libglade>=2
+ depends = curl
+ source = http://downloads.sourceforge.net/gnaughty/gnaughty-1.2.5.tar.gz
+ source = 10-curl-remove_deprecated_header.patch
+ source = 20-fix_links_parser.patch
+ sha256sums = f9773837cb79290117678aa5eaf4ae288e28cff5b25f64e0d0d87b15019e9c53
+ sha256sums = 4e50f2c6f8895ecfd827e75faa722f394bbe4b881d1c0cd266738f2265da7de6
+ sha256sums = be4616577e8282ed56e424ed1c7956183449d854c8faec2fd7262a1d7b3293ea
+
+pkgname = gnaughty
+
diff --git a/10-curl-remove_deprecated_header.patch b/10-curl-remove_deprecated_header.patch
new file mode 100644
index 000000000000..548fd4b07fed
--- /dev/null
+++ b/10-curl-remove_deprecated_header.patch
@@ -0,0 +1,10 @@
+--- src/http.c.orig 2012-05-10 10:28:52.000000000 +0200
++++ src/http.c 2012-05-10 10:29:14.000000000 +0200
+@@ -21,7 +21,6 @@
+ #include <string.h>
+ #include <gtk/gtk.h>
+ #include <curl/curl.h>
+-#include <curl/types.h>
+ #include <curl/easy.h>
+ #include "http.h"
+ #include "callbacks.h"
diff --git a/20-fix_links_parser.patch b/20-fix_links_parser.patch
new file mode 100644
index 000000000000..9731338d6f0e
--- /dev/null
+++ b/20-fix_links_parser.patch
@@ -0,0 +1,45 @@
+--- src/parselinks.c.orig 2012-06-15 21:23:19.000000000 +0200
++++ src/parselinks.c 2012-06-15 21:23:21.000000000 +0200
+@@ -83,10 +83,17 @@
+ {
+ curlink = g_new0(link_t, 1);
+ //if not found
+- if ((pos=strstr(pos, " <a href=\"http://"))==NULL)
++ if ((pos=strstr(pos, " <a href=\"/out.php?u=http\%3A\%2F\%2F"))==NULL)
+ break;
+- else
+- pos+=sizeof(gchar)*10;
++ else {
++ pos+=sizeof(gchar)*21;
++ if (g_strstr_len(pos,75,"clicks.cgi") != NULL) {
++ if ((pos=strstr(pos, "HTML%3Dhttp\%3A\%2F\%2F"))==NULL)
++ break;
++ else
++ pos+=sizeof(gchar)*7;
++ }
++ }
+
+ end=strstr(pos, "\"");
+
+@@ -97,10 +104,10 @@
+ pos=end;
+
+ //get the description of that link
+- if ((pos=strstr(pos, "</a> - "))==NULL)
++ if ((pos=strstr(pos, " - "))==NULL)
+ break;
+ else
+- pos+=7;
++ pos+=3;
+ if((end=strstr(pos, "</li>"))==NULL)
+ {
+ curdesc=g_string_new("");
+@@ -111,7 +118,7 @@
+ g_free (tmp);
+
+ if (g_strstr_len(curdesc->str, 10, " tube ") == NULL) {
+- curlink->url=g_string_new(cururl->str);
++ curlink->url=g_string_new(g_uri_unescape_string(cururl->str,NULL));
+ curlink->desc=g_string_new(curdesc->str);
+ links=g_list_append(links, curlink);
+ } else {
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..15d5b956db91
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Contributor: 3ED <krzysztof1987@gmail.com>
+# Thanks for mail and pkgbuild rabyte..
+
+pkgname=gnaughty
+pkgver=1.2.5
+pkgrel=3
+arch=('i686' 'x86_64')
+pkgdesc="A program to automatically download adult content from internet directories (gtk2)"
+url="http://gnaughty.sourceforge.net/"
+license=('GPL')
+makedepends=('make' 'pkgconfig>=0.9')
+depends=('gconf>=2' 'libglade>=2' 'curl')
+source=(http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz
+ 10-curl-remove_deprecated_header.patch
+ 20-fix_links_parser.patch)
+sha256sums=('f9773837cb79290117678aa5eaf4ae288e28cff5b25f64e0d0d87b15019e9c53'
+ '4e50f2c6f8895ecfd827e75faa722f394bbe4b881d1c0cd266738f2265da7de6'
+ 'be4616577e8282ed56e424ed1c7956183449d854c8faec2fd7262a1d7b3293ea')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ sed 's|GCONF_CONFIG_SOURCE|# GCONF_CONFIG_SOURCE|g' -i Makefile.in
+ patch -Np0 -i "$srcdir/10-curl-remove_deprecated_header.patch"
+ patch -Np0 -i "$srcdir/20-fix_links_parser.patch"
+
+ export LIBS=" -lgthread-2.0"
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --with-gconf-schema-file-dir=/usr/share/gconf/schemas \
+ --disable-schemas-install
+ make
+}
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make DESTDIR="$pkgdir" install
+}