summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgbr2021-04-12 14:50:57 -0300
committergbr2021-04-12 14:50:57 -0300
commit2df2902e6c45195597c6be6bc1b9a30699a99080 (patch)
tree2a7085fc0b1cb9a78bd2b7d40692536bca78bbe9
parent44401234df14dce932544cdf0ee8a649eaa80ab3 (diff)
downloadaur-2df2902e6c45195597c6be6bc1b9a30699a99080.tar.gz
gnethogs v0.2+6+gbb69c6f-3
- package description slightly changed - fixed license - general cleanup
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD23
-rw-r--r--gnethogs.install4
3 files changed, 16 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bcc642956a78..ec17d0d9166a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,11 @@
pkgbase = gnethogs
- pkgdesc = GTK front-end for nethogs
+ pkgdesc = Graphical interface for nethogs using GTK
pkgver = 0.2+6+gbb69c6f
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/mbfoss/gnethogs
install = gnethogs.install
arch = any
- license = GPL
+ license = GPL3
makedepends = git
makedepends = intltool
makedepends = libxml2
diff --git a/PKGBUILD b/PKGBUILD
index 76939e78c4be..4054952873ff 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,11 @@
# Maintainer: gbr <gbr@protonmail.com>
pkgname=gnethogs
pkgver=0.2+6+gbb69c6f
-pkgrel=2
-pkgdesc='GTK front-end for nethogs'
+pkgrel=3
+pkgdesc='Graphical interface for nethogs using GTK'
arch=('any')
url='https://github.com/mbfoss/gnethogs'
-_commit=
-license=('GPL')
+license=('GPL3')
depends=('gtkmm3' 'nethogs')
makedepends=('git' 'intltool' 'libxml2')
_commit=bb69c6f82e059a451174c24a6bb1a21b32173f6c
@@ -15,18 +14,18 @@ sha512sums=('SKIP')
install=gnethogs.install
pkgver() {
- cd "$pkgname"
- git describe --tags | sed 's/^v//g; s/-/+/g'
+ cd "$pkgname"
+ git describe --tags | sed 's/^v//g; s/-/+/g'
}
build() {
- cd "$pkgname"
- ./autogen.sh
- ./configure --prefix=/usr
- make
+ cd "$pkgname"
+ ./autogen.sh
+ ./configure --prefix=/usr
+ make
}
package() {
- cd "$pkgname"
- make DESTDIR="$pkgdir" install
+ cd "$pkgname"
+ make DESTDIR="$pkgdir" install
}
diff --git a/gnethogs.install b/gnethogs.install
index c211289c0ac2..ec8475824ac7 100644
--- a/gnethogs.install
+++ b/gnethogs.install
@@ -1,7 +1,7 @@
post_install() {
- setcap 'cap_net_raw+ep' usr/bin/gnethogs
+ setcap 'cap_net_raw+ep' 'usr/bin/gnethogs'
}
post_upgrade() {
- post_install "$1"
+ post_install "$1"
}