summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarsten Teibes2013-11-10 23:02:21 +0100
committerCarsten Teibes2013-11-10 23:02:21 +0100
commit9d806607cc8a5dc0e7506745c52320bbea7c16ba (patch)
tree4eb9bdef49a40d2ef7ab13564e0db961f714d154
downloadaur-9d806607cc8a5dc0e7506745c52320bbea7c16ba.tar.gz
[add] gngeo-hg
-rw-r--r--.SRCINFO32
-rw-r--r--PKGBUILD66
-rw-r--r--gngeo-hg.install6
-rw-r--r--gngeo.desktop9
-rw-r--r--gngeo.pngbin0 -> 2249 bytes
5 files changed, 113 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b8a136c37591
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,32 @@
+pkgbase = gngeo-hg
+ pkgdesc = A portable command-line NeoGeo Emulator (development version).
+ pkgver = 0.8.r95.6ad2a3d1bba3
+ pkgrel = 1
+ url = https://code.google.com/p/gngeo/
+ install = gngeo-hg.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ license = custom
+ makedepends = mercurial
+ makedepends = nasm
+ depends = zlib
+ depends = sdl
+ optdepends = libgl: OpenGL renderer backend
+ provides = gngeo
+ conflicts = gngeo
+ source = gngeo::hg+https://code.google.com/p/gngeo/
+ source = gngeo.desktop
+ source = gngeo.png
+ source = gngeo-hg.install
+ md5sums = SKIP
+ md5sums = 0e45bc9cf87a61bd3b92fb27c6a87dbd
+ md5sums = 25321e134708b239199c6ba49a9a2248
+ md5sums = fa2be7e60f3390bbd4137f0dd593a2f7
+ sha256sums = SKIP
+ sha256sums = f1844db27e0f2d8046a107b0279c76c19a89f7d824da80590e93ea24382c3785
+ sha256sums = b543425d51bd669fe5081b0b89492f18163c292194ac2a4acff683ba2a60063e
+ sha256sums = a1fe0ad7b8f601abcca92650e225c28af45db0b9eb4d96f3bdc055af0fe5c635
+
+pkgname = gngeo-hg
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..da8275b74eee
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,66 @@
+# Maintainer: carstene1ns <arch carsten-teibes de>
+
+_pkgbase=gngeo
+pkgname=$_pkgbase-hg
+pkgver=0.8.r95.6ad2a3d1bba3
+pkgrel=1
+pkgdesc="A portable command-line NeoGeo Emulator (development version)."
+arch=('i686' 'x86_64')
+url="https://code.google.com/p/gngeo/"
+license=('GPL' 'custom')
+depends=('zlib' 'sdl')
+optdepends=('libgl: OpenGL renderer backend')
+makedepends=('mercurial' 'nasm')
+# nasm is x86-only
+[ "$CARCH" == "x86_64" ] && makedepends=('mercurial')
+conflicts=("$_pkgbase")
+provides=("$_pkgbase")
+install="$pkgname.install"
+source=("$_pkgbase"::"hg+$url"
+ "$_pkgbase.desktop"
+ "$_pkgbase.png"
+ "$pkgname.install")
+md5sums=('SKIP'
+ '0e45bc9cf87a61bd3b92fb27c6a87dbd'
+ '25321e134708b239199c6ba49a9a2248'
+ 'fa2be7e60f3390bbd4137f0dd593a2f7')
+sha256sums=('SKIP'
+ 'f1844db27e0f2d8046a107b0279c76c19a89f7d824da80590e93ea24382c3785'
+ 'b543425d51bd669fe5081b0b89492f18163c292194ac2a4acff683ba2a60063e'
+ 'a1fe0ad7b8f601abcca92650e225c28af45db0b9eb4d96f3bdc055af0fe5c635')
+
+pkgver() {
+ cd "$srcdir/$_pkgbase"
+
+ # get latest tag, revision count and commit identifier
+ printf "%s.r%s.%s" "$(hg parents --template {latesttag} | sed 's/gngeo_//')" \
+ "$(hg identify -n)" "$(hg identify -i)"
+}
+
+prepare() {
+ cd "$srcdir/$_pkgbase"
+
+ # change path
+ sed 's#games/lib#share#' -i sample_gngeorc
+}
+
+build() {
+ cd "$srcdir/$_pkgbase"
+
+ ./configure --prefix=/usr
+
+ # force single threaded build
+ make -j1
+}
+
+package() {
+ cd "$srcdir/$_pkgbase"
+
+ make DESTDIR="$pkgdir" install
+
+ # install icon, .desktop, sample config and license file
+ install -Dm644 "$srcdir/$_pkgbase.png" "$pkgdir/usr/share/pixmaps/$_pkgbase.png"
+ install -Dm644 "$srcdir/$_pkgbase.desktop" "$pkgdir/usr/share/applications/$_pkgbase.desktop"
+ install -Dm644 sample_gngeorc "$pkgdir/usr/share/$_pkgbase/sample_gngeorc"
+ install -Dm644 COPYING "$pkgdir/usr/share/licenses/$_pkgbase/COPYING"
+}
diff --git a/gngeo-hg.install b/gngeo-hg.install
new file mode 100644
index 000000000000..cf3f1a033ac5
--- /dev/null
+++ b/gngeo-hg.install
@@ -0,0 +1,6 @@
+
+post_install()
+{
+ echo "See /usr/share/gngeo/sample_gngeorc for a sample configuration file" \
+ "and save your config to ~/.gngeo/gngeorc file."
+}
diff --git a/gngeo.desktop b/gngeo.desktop
new file mode 100644
index 000000000000..9981b37892dc
--- /dev/null
+++ b/gngeo.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Type=Application
+Version=1.0
+Name=gngeo
+Comment=portable NeoGeo Emulator
+Exec=gngeo
+Icon=gngeo
+Terminal=false
+Categories=Game;Emulator
diff --git a/gngeo.png b/gngeo.png
new file mode 100644
index 000000000000..fb495e63f412
--- /dev/null
+++ b/gngeo.png
Binary files differ