summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYour Name2021-08-16 11:56:24 +0200
committerYour Name2021-08-16 11:56:24 +0200
commit3c75b23ce539417f8f2944208480b99d695604b1 (patch)
tree2ebf7861a19654853ab51ed9b56eefaddd948137
downloadaur-3c75b23ce539417f8f2944208480b99d695604b1.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD31
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7a3fb2acf6bc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = gnirehtet-bin
+ pkgdesc = Gnirehtet provides reverse tethering for Android
+ pkgver = 2.5
+ pkgrel = 1
+ url = https://github.com/Genymobile/gnirehtet
+ arch = x86_64
+ license = Apache-2.0
+ provides = gnirehtet
+ conflicts = gnirehtet
+ conflicts = gnirehtet-git
+ source = https://github.com/Genymobile/gnirehtet/releases/download/v2.5/gnirehtet-rust-linux64-v2.5.zip
+ source = https://raw.githubusercontent.com/Genymobile/gnirehtet/master/LICENSE
+ sha256sums = 2b1ce04540e8de5df5ddbebb64bb01e27c13d556b3a04a8563dcce3786765705
+ sha256sums = SKIP
+
+pkgname = gnirehtet-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d1d825e1759c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Brodi <me@brodi.space>
+_pkgname=gnirehtet
+pkgname=${_pkgname}-bin
+pkgver=2.5
+pkgrel=1
+pkgdesc="Gnirehtet provides reverse tethering for Android"
+arch=("x86_64")
+url="https://github.com/Genymobile/gnirehtet"
+license=("Apache-2.0")
+provides=("${_pkgname}")
+conflicts=("${_pkgname}" "${_pkgname}-git")
+
+source=(
+ "${url}/releases/download/v${pkgver}/gnirehtet-rust-linux64-v${pkgver}.zip"
+ "https://raw.githubusercontent.com/Genymobile/gnirehtet/master/LICENSE"
+)
+
+sha256sums=(
+ "2b1ce04540e8de5df5ddbebb64bb01e27c13d556b3a04a8563dcce3786765705"
+ "SKIP"
+)
+
+package() {
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE"
+ install -d "${pkgdir}/usr/share/${_pkgname}"
+
+ cd ${srcdir}/${_pkgname}-rust-linux64
+ install -Dm755 ${_pkgname}.apk "${pkgdir}/usr/share/${_pkgname}"
+ install -Dm755 ${_pkgname} "${pkgdir}/usr/bin/${_pkgname}"
+}
+