summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDoug Penner2015-09-14 22:19:47 -0700
committerDoug Penner2015-09-14 22:19:47 -0700
commitbc73ccb6a774754d42013f634cb3c42e4f714d54 (patch)
tree4a0e7fec53221ffc96ffe6b2e0fc4f667b65cf59
downloadaur-bc73ccb6a774754d42013f634cb3c42e4f714d54.tar.gz
initial aur4 commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD26
-rw-r--r--gnocky.install12
3 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5a6e5d6e33b0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = gnocky
+ pkgdesc = GTK written GUI frontend for gnokii
+ pkgver = 0.0.7
+ pkgrel = 2
+ url = http://www.gnokii.org/
+ install = gnocky.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = make
+ makedepends = gcc
+ depends = libglade
+ depends = gnokii>=0.6.26
+ depends = libical
+ source = http://www.gnokii.org/download/gnocky/gnocky-0.0.7.tar.gz
+ md5sums = 607b25ee3bbfc0cee5664018c302d8e0
+
+pkgname = gnocky
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2fdcb0373afe
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Current Contributor: Doug Penner <darwinsurvivor@gmail.com>
+# Past Contributor: Marco Praher <marco.praher@gmx.at>
+pkgname=gnocky
+pkgver=0.0.7
+pkgrel=2
+pkgdesc='GTK written GUI frontend for gnokii'
+arch=('i686' 'x86_64')
+url='http://www.gnokii.org/'
+license=('GPL')
+depends=('libglade' 'gnokii>=0.6.26' 'libical')
+makedepends=('make' 'gcc')
+install='gnocky.install'
+source=("http://www.gnokii.org/download/$pkgname/$pkgname-$pkgver.tar.gz")
+md5sums=('607b25ee3bbfc0cee5664018c302d8e0')
+
+build() {
+ cd $srcdir/$pkgname-$pkgver
+ ./configure LIBS=-lgthread-2.0
+ make
+}
+
+package() {
+ cd $srcdir/$pkgname-$pkgver
+ make prefix=$pkgdir/usr/share/gnocky install
+}
+
diff --git a/gnocky.install b/gnocky.install
new file mode 100644
index 000000000000..3b306f8b2442
--- /dev/null
+++ b/gnocky.install
@@ -0,0 +1,12 @@
+post_install() {
+ ln -s /usr/share/gnocky/bin/gnocky /usr/bin/gnocky
+}
+
+pre_remove() {
+ rm /usr/bin/gnocky
+}
+
+op=$1
+shift
+
+$op "$@"