summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlbert Graef2015-06-13 22:55:59 +0200
committerAlbert Graef2015-06-13 22:55:59 +0200
commit956d6b0fd6925059ab8a2733af40f15fe4ed1f27 (patch)
treef1d3fceb5f3ae9dbf8bb91c40ac69597029b4fb6
downloadaur-956d6b0fd6925059ab8a2733af40f15fe4ed1f27.tar.gz
Initial import
-rw-r--r--.AURINFO19
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD30
-rw-r--r--gnocl-0.9.96+20130131.patch91
4 files changed, 159 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..e16b1866efc8
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,19 @@
+pkgbase = gnocl
+ pkgdesc = Tcl/GTK+ bindings
+ pkgver = 0.9.96+20130131
+ pkgrel = 1
+ url = http://www.gnocl.org/
+ arch = i686
+ arch = x86_64
+ license = custom
+ depends = tcl
+ depends = gtk2
+ depends = libglade
+ depends = libnotify
+ source = https://launchpad.net/~dr-graef/+archive/gnocl.precise/+files/gnocl_0.9.96+20130131.orig.tar.bz2
+ source = gnocl-0.9.96+20130131.patch
+ md5sums = f36639e8cc1236e4e240f406a936ccd3
+ md5sums = 729c0c47ca108f1adb219605b0c7006b
+
+pkgname = gnocl
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e16b1866efc8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = gnocl
+ pkgdesc = Tcl/GTK+ bindings
+ pkgver = 0.9.96+20130131
+ pkgrel = 1
+ url = http://www.gnocl.org/
+ arch = i686
+ arch = x86_64
+ license = custom
+ depends = tcl
+ depends = gtk2
+ depends = libglade
+ depends = libnotify
+ source = https://launchpad.net/~dr-graef/+archive/gnocl.precise/+files/gnocl_0.9.96+20130131.orig.tar.bz2
+ source = gnocl-0.9.96+20130131.patch
+ md5sums = f36639e8cc1236e4e240f406a936ccd3
+ md5sums = 729c0c47ca108f1adb219605b0c7006b
+
+pkgname = gnocl
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..88614c3740ae
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Albert Graef <aggraef@gmail.com>
+
+pkgname=gnocl
+pkgver=0.9.96+20130131
+_pkgver=0.9.96
+pkgrel=1
+pkgdesc="Tcl/GTK+ bindings"
+arch=("i686" "x86_64")
+license=('custom')
+url="http://www.gnocl.org/"
+depends=('tcl' 'gtk2' 'libglade' 'libnotify')
+makedepends=()
+source=("https://launchpad.net/~dr-graef/+archive/gnocl.precise/+files/${pkgname}_${pkgver}.orig.tar.bz2"
+ "$pkgname-$pkgver.patch")
+md5sums=('f36639e8cc1236e4e240f406a936ccd3'
+ '729c0c47ca108f1adb219605b0c7006b')
+
+build() {
+ cd $srcdir/$pkgname-$_pkgver
+ patch -p1 < ../$pkgname-$pkgver.patch
+ cd src
+ chmod 0644 pkgIndex.tcl
+ make
+}
+
+package() {
+ cd $srcdir/$pkgname-$_pkgver/src
+ make DESTDIR=$pkgdir install devinstall
+ install -D -m644 ../license.terms "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
diff --git a/gnocl-0.9.96+20130131.patch b/gnocl-0.9.96+20130131.patch
new file mode 100644
index 000000000000..221291f48618
--- /dev/null
+++ b/gnocl-0.9.96+20130131.patch
@@ -0,0 +1,91 @@
+diff -rup gnocl-0.9.96.orig/src/Makefile gnocl-0.9.96/src/Makefile
+--- gnocl-0.9.96.orig/src/Makefile 2013-01-31 10:52:21.000000000 +0100
++++ gnocl-0.9.96/src/Makefile 2013-09-09 22:58:42.511541653 +0200
+@@ -142,15 +142,15 @@ clean:
+ rm -f $(GTK_OBJ) $(PACKAGE_NAME).so
+
+ install:
+- ./install.tcl $(PACKAGE_REQUIRE_NAME) $(VERSION) $(PACKAGE_NAME) install
++ ./install.tcl $(PACKAGE_REQUIRE_NAME) $(VERSION) $(PACKAGE_NAME) install $(DESTDIR)
+
+
+ uninstall:
+- ./install.tcl $(PACKAGE_REQUIRE_NAME) $(VERSION) $(PACKAGE_NAME) uninstall
++ ./install.tcl $(PACKAGE_REQUIRE_NAME) $(VERSION) $(PACKAGE_NAME) uninstall $(DESTDIR)
+
+ reinstall:
+- ./install.tcl $(PACKAGE_REQUIRE_NAME) $(VERSION) $(PACKAGE_NAME) uninstall
+- ./install.tcl $(PACKAGE_REQUIRE_NAME) $(VERSION) $(PACKAGE_NAME) install
++ ./install.tcl $(PACKAGE_REQUIRE_NAME) $(VERSION) $(PACKAGE_NAME) uninstall $(DESTDIR)
++ ./install.tcl $(PACKAGE_REQUIRE_NAME) $(VERSION) $(PACKAGE_NAME) install $(DESTDIR)
+
+ test:
+ ( \
+@@ -161,10 +161,12 @@ test:
+
+ devinstall:
+ ar cr libgnocl-$(VERSION).a $(GTK_OBJ)
+- cp gnocl*.h /usr/include
+- cp libgnocl*.a /usr/lib
++ test -d $(DESTDIR)/usr/include || mkdir -p $(DESTDIR)/usr/include
++ cp gnocl.h gnoclparams.h $(DESTDIR)/usr/include
++ test -d $(DESTDIR)/usr/lib || mkdir -p $(DESTDIR)/usr/lib
++ cp libgnocl*.a $(DESTDIR)/usr/lib
+ rm libgnocl*.a
+
+ devuninstall:
+- rm /usr/include/gnocl*.h
+- rm /usr/lib/libgnocl*.a
++ rm -f $(DESTDIR)/usr/include/gnocl*.h
++ rm -f $(DESTDIR)/usr/lib/libgnocl*.a
+diff -rup gnocl-0.9.96.orig/src/install.tcl gnocl-0.9.96/src/install.tcl
+--- gnocl-0.9.96.orig/src/install.tcl 2013-01-31 10:52:21.000000000 +0100
++++ gnocl-0.9.96/src/install.tcl 2013-09-09 23:01:54.721552241 +0200
+@@ -36,13 +36,13 @@ proc date { {i date} } {
+ }
+
+ # error checking
+-if { $argc != 4 } {
++if { $argc < 4 || $argc > 5 } {
+ set name [file tail $argv0]
+ error "Wrong number of args.\nUsage: $name package version install/uninstall"
+ }
+
+ # get parameters
+-foreach {package version name what} $argv { break }
++foreach {package version name what dest} $argv { break }
+
+ # get installation directory
+ set dir [info library]
+@@ -51,7 +51,7 @@ set dir [info library]
+ set destDir [file join $dir $name$version]
+ switch -- $what {
+ "install" {
+- if { [file exists $destDir] } {
++ if { [file exists $dest$destDir] } {
+ puts "$destDir exists already. Aborting installation."
+ exit -1
+ }
+@@ -70,18 +70,18 @@ switch -- $what {
+ puts $fp "package ifneeded $package $version \[list load \[file join \$dir $name.so\]\]"
+ close $fp
+ puts "Creating $destDir"
+- file mkdir $destDir
++ file mkdir $dest$destDir
+ set files [glob *.so]
+ lappend files pkgIndex.tcl
+ foreach file $files {
+ puts "Copying $file"
+- file copy $file $destDir
+- exec chmod 444 $file
++ file copy $file $dest$destDir
++ exec chmod 644 $file
+ }
+ }
+ "uninstall" {
+ puts "Deleting $destDir"
+- file delete -force $destDir
++ file delete -force $dest$destDir
+ }
+ default {
+ error "unknown type \"$what\" must be install, test or uninstall"