summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntonio Rojas2021-05-08 09:13:19 +0000
committerAntonio Rojas2021-05-08 09:13:19 +0000
commit6b8b0666bee69d4bf4609301f5ad2db683c234f2 (patch)
treefe54c8f58a79811eefc2eeceafcaf20c2b8b60d4
downloadaur-gnokii.tar.gz
Dropped from repos
-rw-r--r--.SRCINFO36
-rw-r--r--PKGBUILD75
-rw-r--r--gnokii-config.patch12
-rw-r--r--gnokii-gcc5.patch27
-rw-r--r--gnokii-gcc7.patch13
-rw-r--r--gnokii-lock.patch15
-rw-r--r--gnokii.install3
7 files changed, 181 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a3ba54279d0a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,36 @@
+pkgbase = gnokii
+ pkgdesc = Tools and user space driver for use with mobile phones
+ pkgver = 0.6.31
+ pkgrel = 19
+ url = https://www.gnokii.org/
+ install = gnokii.install
+ arch = x86_64
+ license = GPL
+ makedepends = gtk2
+ makedepends = mariadb-libs
+ makedepends = postgresql-libs
+ makedepends = intltool
+ depends = libusb-compat
+ depends = libxpm
+ depends = bluez-libs
+ depends = libical
+ depends = sqlite
+ depends = systemd
+ optdepends = dialog: sendsms tool
+ optdepends = gtk2: xgnokii GUI
+ optdepends = mariadb-libs: smsd mysql backend
+ optdepends = postgresql-libs: smsd postgresql backend
+ backup = etc/gnokiirc
+ source = https://www.gnokii.org/download/gnokii/gnokii-0.6.31.tar.bz2
+ source = gnokii-config.patch
+ source = gnokii-lock.patch
+ source = gnokii-gcc5.patch
+ source = gnokii-gcc7.patch
+ sha256sums = 8f5a083b05c1a66a3402ca5cd80084e14c2c0632c991bb53b03c78e9adb02501
+ sha256sums = 4c795f0b80b3703a2813adb32399b42080a01670619c1db63ab094494cb6f329
+ sha256sums = e0584a44268e9055b43f1673d7db828f45294c5108635ebd5f664e12703f108b
+ sha256sums = eafe67990e383e92636a88de27f003674374db81d986ddbb397ab18d82b6556d
+ sha256sums = a5db8684216904bd2a2cd8a557dcc16484831b9bc2ec91a0b102b14c3bfe9245
+
+pkgname = gnokii
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e701965a6337
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,75 @@
+# Maintainer: Balló György <ballogyor+arch at gmail dot com>
+# Contributor: Andrea Scarpino <andrea@archlinux.org>
+# Contributor: Roman Kyrylych <roman@archlinux.org>
+# Contributor: Aurelien Foret <orelien@chez.com>
+
+pkgname=gnokii
+pkgver=0.6.31
+pkgrel=19
+pkgdesc='Tools and user space driver for use with mobile phones'
+arch=('x86_64')
+url='https://www.gnokii.org/'
+license=('GPL')
+depends=('libusb-compat' 'libxpm' 'bluez-libs' 'libical' 'sqlite' 'systemd')
+makedepends=('gtk2' 'mariadb-libs' 'postgresql-libs' 'intltool')
+optdepends=('dialog: sendsms tool'
+ 'gtk2: xgnokii GUI'
+ 'mariadb-libs: smsd mysql backend'
+ 'postgresql-libs: smsd postgresql backend')
+backup=('etc/gnokiirc')
+install=$pkgname.install
+source=("https://www.gnokii.org/download/$pkgname/$pkgname-$pkgver.tar.bz2"
+ 'gnokii-config.patch'
+ 'gnokii-lock.patch'
+ 'gnokii-gcc5.patch'
+ 'gnokii-gcc7.patch')
+sha256sums=('8f5a083b05c1a66a3402ca5cd80084e14c2c0632c991bb53b03c78e9adb02501'
+ '4c795f0b80b3703a2813adb32399b42080a01670619c1db63ab094494cb6f329'
+ 'e0584a44268e9055b43f1673d7db828f45294c5108635ebd5f664e12703f108b'
+ 'eafe67990e383e92636a88de27f003674374db81d986ddbb397ab18d82b6556d'
+ 'a5db8684216904bd2a2cd8a557dcc16484831b9bc2ec91a0b102b14c3bfe9245')
+
+prepare() {
+ cd $pkgname-$pkgver
+
+ # Set bindir location
+ patch -Np1 -i ../gnokii-config.patch
+
+ # Set lock path
+ patch -Np1 -i ../gnokii-lock.patch
+
+ # Fix build with GCC 5 (Fedora patch)
+ patch -Np1 -i ../gnokii-gcc5.patch
+
+ # Fix build with GCC 7
+ patch -Np1 -i ../gnokii-gcc7.patch
+}
+
+build() {
+ cd $pkgname-$pkgver
+ ./configure --prefix=/usr --sysconfdir=/etc --sbindir=/usr/bin \
+ --enable-security
+ make
+ pushd xgnokii
+ make
+ popd
+}
+
+package() {
+ cd $pkgname-$pkgver
+
+ make DESTDIR="$pkgdir" install
+ pushd xgnokii
+ make DESTDIR="$pkgdir" install
+ popd
+
+ # Install initial config file
+ install -Dm644 Docs/sample/gnokiirc "$pkgdir/etc/gnokiirc"
+
+ # Fix file permission
+ chmod 755 "$pkgdir/usr/bin/sendsms"
+
+ # Setup lock directory
+ install -dm755 "$pkgdir"/usr/lib/tmpfiles.d
+ echo 'd /run/lock/lockdev 0775 root lock -' > "$pkgdir/usr/lib/tmpfiles.d/$pkgname.conf"
+}
diff --git a/gnokii-config.patch b/gnokii-config.patch
new file mode 100644
index 000000000000..c10d19cec4e4
--- /dev/null
+++ b/gnokii-config.patch
@@ -0,0 +1,12 @@
+diff -Nura gnokii-0.6.31.orig/Docs/sample/gnokiirc gnokii-0.6.31/Docs/sample/gnokiirc
+--- gnokii-0.6.31.orig/Docs/sample/gnokiirc 2011-12-02 15:53:04.000000000 +0100
++++ gnokii-0.6.31/Docs/sample/gnokiirc 2012-02-18 12:49:26.957557504 +0100
+@@ -238,7 +238,7 @@
+ # In particular ensure that mgnokiidev is in this location, with
+ # permissions 4750, owned by root, group gnokii. Ensure you
+ # are in the gnokii group and that the group exists...
+-bindir = /usr/local/sbin/
++bindir = /usr/bin/
+
+ # Any entries in the following two sections will be set as environment
+ # variables when running the scripts.
diff --git a/gnokii-gcc5.patch b/gnokii-gcc5.patch
new file mode 100644
index 000000000000..09b65f5b0f81
--- /dev/null
+++ b/gnokii-gcc5.patch
@@ -0,0 +1,27 @@
+Patch by Robert Scheck <robert@fedoraproject.org> for gnokii <= 0.6.31 to avoid
+build failures with GCC 5.x as "gnokii-0.6.31/xgnokii/xgnokii.c:1209: undefined
+reference to `GUI_HideAbout'" and "xgnokii-xgnokii_logos.o:(.data.rel+0xe0):
+undefined reference to `CloseLogosWindow'".
+
+--- gnokii-0.6.31/xgnokii/xgnokii.c 2011-12-02 15:53:04.000000000 +0100
++++ gnokii-0.6.31/xgnokii/xgnokii.c.gcc5 2015-06-20 15:49:59.000000000 +0200
+@@ -798,7 +798,7 @@
+ }
+
+
+-inline void GUI_HideAbout(void)
++void GUI_HideAbout(void)
+ {
+ gtk_widget_hide(AboutDialog);
+ }
+--- gnokii-0.6.31/xgnokii/xgnokii_logos.c 2011-12-02 15:53:04.000000000 +0100
++++ gnokii-0.6.31/xgnokii/xgnokii_logos.c.gcc5 2015-06-20 15:50:15.000000000 +0200
+@@ -1304,7 +1304,7 @@
+ return 0;
+ }
+
+-inline void CloseLogosWindow(void)
++void CloseLogosWindow(void)
+ {
+ gtk_widget_hide(GUI_LogosWindow);
+ }
diff --git a/gnokii-gcc7.patch b/gnokii-gcc7.patch
new file mode 100644
index 000000000000..24fc9c9b13a5
--- /dev/null
+++ b/gnokii-gcc7.patch
@@ -0,0 +1,13 @@
+diff --git a/common/gsm-filetypes.c b/common/gsm-filetypes.c
+index b4ceea1..264420a 100644
+--- a/common/gsm-filetypes.c
++++ b/common/gsm-filetypes.c
+@@ -1409,7 +1409,7 @@ static int get_next_token(char *src, int delim)
+ #define GET_NEXT_TOKEN() o = get_next_token(line + offset, ';')
+ #define STORE_TOKEN(a) strip_slashes(a, line + offset, sizeof(a) - 1, o - 1)
+
+-inline int local_atoi(char *str, int len)
++int local_atoi(char *str, int len)
+ {
+ int retval;
+ char *aux = strndup(str, len);
diff --git a/gnokii-lock.patch b/gnokii-lock.patch
new file mode 100644
index 000000000000..61bcfaf405fb
--- /dev/null
+++ b/gnokii-lock.patch
@@ -0,0 +1,15 @@
+diff -Naur gnokii-0.6.31.orig/common/misc.c gnokii-0.6.31/common/misc.c
+--- gnokii-0.6.31.orig/common/misc.c 2011-12-02 15:53:04.000000000 +0100
++++ gnokii-0.6.31/common/misc.c 2013-08-12 18:38:41.021668458 +0200
+@@ -448,9 +448,9 @@
+
+ #define BUFFER_MAX_LENGTH 128
+ #if defined (__svr4__)
+-# define lock_path "/var/run/LCK.."
++# define lock_path "/var/run/lockdev/LCK.."
+ #else
+-# define lock_path "/var/lock/LCK.."
++# define lock_path "/var/lock/lockdev/LCK.."
+ #endif
+
+ /* Lock the device. Return allocated string with a lock name */
diff --git a/gnokii.install b/gnokii.install
new file mode 100644
index 000000000000..354b345a2072
--- /dev/null
+++ b/gnokii.install
@@ -0,0 +1,3 @@
+post_install() {
+ echo "Users need to be in 'lock' and 'uucp' groups to connect to devices"
+}