summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCork2015-07-12 13:00:05 +0200
committerCork2015-07-12 13:00:05 +0200
commit7382adf17dab026bb8497c1b9880285580587e5d (patch)
tree243345f2ff7067ea186f3d04571c26e6d5156ed0
downloadaur-7382adf17dab026bb8497c1b9880285580587e5d.tar.gz
Initial import
-rw-r--r--.SRCINFO33
-rw-r--r--PKGBUILD79
-rw-r--r--gnokii-config.patch12
-rw-r--r--gnokii-lock.patch15
-rw-r--r--gnokii.install3
5 files changed, 142 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9e1805465c81
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,33 @@
+pkgbase = gnokii-git
+ pkgdesc = Tools and user space driver for use with mobile phones
+ pkgver = r5004.187de67
+ pkgrel = 1
+ url = http://www.gnokii.org/
+ install = gnokii.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = gtk2
+ makedepends = libmariadbclient
+ makedepends = postgresql-libs
+ makedepends = intltool
+ depends = libusb-compat
+ depends = libxpm
+ depends = bluez-libs
+ depends = libical
+ depends = sqlite
+ optdepends = dialog: sendsms tool
+ optdepends = gtk2: xgnokii GUI
+ optdepends = libmariadbclient: smsd mysql backend
+ optdepends = postgresql-libs: smsd postgresql backend
+ conflicts = gnokii
+ backup = etc/gnokiirc
+ source = gnokii::git://git.savannah.nongnu.org/gnokii.git
+ source = gnokii-config.patch
+ source = gnokii-lock.patch
+ md5sums = SKIP
+ md5sums = b2961b52ac1f770c4704ccc50b64fde2
+ md5sums = 17b629db85a6bb2b98ca59941aa95295
+
+pkgname = gnokii-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9fa5e2b22083
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,79 @@
+# $Id$
+# Maintainer: Balló György <ballogyor+arch at gmail dot com>
+# Contributor: Andrea Scarpino <andrea@archlinux.org>
+# Contributor: Roman Kyrylych <roman@archlinux.org>
+# Contributor: Aurelien Foret <orelien@chez.com>
+
+_gitname=gnokii
+pkgname=${_gitname}-git
+pkgver=r5004.187de67
+pkgrel=1
+pkgdesc="Tools and user space driver for use with mobile phones"
+arch=('i686' 'x86_64')
+url="http://www.gnokii.org/"
+license=('GPL')
+depends=('libusb-compat' 'libxpm' 'bluez-libs' 'libical' 'sqlite')
+makedepends=('git' 'gtk2' 'libmariadbclient' 'postgresql-libs' 'intltool')
+optdepends=('dialog: sendsms tool'
+ 'gtk2: xgnokii GUI'
+ 'libmariadbclient: smsd mysql backend'
+ 'postgresql-libs: smsd postgresql backend')
+conflicts=('gnokii')
+backup=('etc/gnokiirc')
+install="${_gitname}.install"
+source=("${_gitname}::git://git.savannah.nongnu.org/${_gitname}.git"
+ 'gnokii-config.patch'
+ 'gnokii-lock.patch')
+md5sums=('SKIP'
+ 'b2961b52ac1f770c4704ccc50b64fde2'
+ '17b629db85a6bb2b98ca59941aa95295')
+
+pkgver() {
+ cd "${srcdir}/${_gitname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd ${_gitname}
+
+ # Set bindir location
+ patch -Np1 -i "${srcdir}/gnokii-config.patch"
+
+ # Set lock path
+ patch -Np1 -i "${srcdir}/gnokii-lock.patch"
+}
+
+build() {
+ cd ${_gitname}
+
+ libtoolize -c -f
+ glib-gettextize -f
+ intltoolize --force --copy --automake
+ aclocal -I m4
+ autoheader -I m4
+ automake --add-missing
+ autoconf
+
+ ./configure --prefix=/usr --sysconfdir=/etc --sbindir=/usr/bin \
+ --disable-static --enable-security
+ make
+ pushd xgnokii
+ make
+ popd
+}
+
+package() {
+ cd ${_gitname}
+
+ make DESTDIR="${pkgdir}" install
+ pushd xgnokii
+ make DESTDIR="${pkgdir}" install
+ popd
+
+ # Install inital config file
+ install -Dm644 Docs/sample/gnokiirc "${pkgdir}/etc/gnokiirc"
+
+ # Fix file permission
+ chmod 755 "${pkgdir}/usr/bin/sendsms"
+}
+
diff --git a/gnokii-config.patch b/gnokii-config.patch
new file mode 100644
index 000000000000..c10d19cec4e4
--- /dev/null
+++ b/gnokii-config.patch
@@ -0,0 +1,12 @@
+diff -Nura gnokii-0.6.31.orig/Docs/sample/gnokiirc gnokii-0.6.31/Docs/sample/gnokiirc
+--- gnokii-0.6.31.orig/Docs/sample/gnokiirc 2011-12-02 15:53:04.000000000 +0100
++++ gnokii-0.6.31/Docs/sample/gnokiirc 2012-02-18 12:49:26.957557504 +0100
+@@ -238,7 +238,7 @@
+ # In particular ensure that mgnokiidev is in this location, with
+ # permissions 4750, owned by root, group gnokii. Ensure you
+ # are in the gnokii group and that the group exists...
+-bindir = /usr/local/sbin/
++bindir = /usr/bin/
+
+ # Any entries in the following two sections will be set as environment
+ # variables when running the scripts.
diff --git a/gnokii-lock.patch b/gnokii-lock.patch
new file mode 100644
index 000000000000..61bcfaf405fb
--- /dev/null
+++ b/gnokii-lock.patch
@@ -0,0 +1,15 @@
+diff -Naur gnokii-0.6.31.orig/common/misc.c gnokii-0.6.31/common/misc.c
+--- gnokii-0.6.31.orig/common/misc.c 2011-12-02 15:53:04.000000000 +0100
++++ gnokii-0.6.31/common/misc.c 2013-08-12 18:38:41.021668458 +0200
+@@ -448,9 +448,9 @@
+
+ #define BUFFER_MAX_LENGTH 128
+ #if defined (__svr4__)
+-# define lock_path "/var/run/LCK.."
++# define lock_path "/var/run/lockdev/LCK.."
+ #else
+-# define lock_path "/var/lock/LCK.."
++# define lock_path "/var/lock/lockdev/LCK.."
+ #endif
+
+ /* Lock the device. Return allocated string with a lock name */
diff --git a/gnokii.install b/gnokii.install
new file mode 100644
index 000000000000..e0ddf215d707
--- /dev/null
+++ b/gnokii.install
@@ -0,0 +1,3 @@
+post_install() {
+echo "Users need to be in 'lock' and 'uucp' groups to connect to devices"
+}