summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilip Goto2022-12-20 12:31:38 +0100
committerPhilip Goto2022-12-20 12:31:38 +0100
commit5fe4e68be09328c2a482b27ff3d1114ee3555ac6 (patch)
tree7ccf6042d64c9f7f2fc56b6cc223846214d54838
parent18aa91c6c8b0c677ca6ea2a7b0d5c674d68379a9 (diff)
downloadaur-5fe4e68be09328c2a482b27ff3d1114ee3555ac6.tar.gz
Update and refactor
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD32
2 files changed, 20 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c0947127a757..245cd86c9414 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,17 @@
pkgbase = gnome-backgrounds-git
pkgdesc = Background images and data for GNOME
- pkgver = 3.37.92+3+gae42bef
+ pkgver = 43.r8.g5966cc2
pkgrel = 1
url = https://gitlab.gnome.org/GNOME/gnome-backgrounds
arch = any
- groups = gnome
- license = GPL
+ license = CCPL:by-sa
makedepends = git
makedepends = glib2
makedepends = meson
+ depends = webp-pixbuf-loader
provides = gnome-backgrounds
conflicts = gnome-backgrounds
source = git+https://gitlab.gnome.org/GNOME/gnome-backgrounds.git
- sha256sums = SKIP
+ b2sums = SKIP
pkgname = gnome-backgrounds-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 74f6ef001c59..668b38a954aa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,33 @@
+# Maintainer: Philip Goto <philip.goto@gmail.com>
+
pkgname=gnome-backgrounds-git
-pkgver=3.37.92+3+gae42bef
+pkgver=43.r8.g5966cc2
pkgrel=1
-pkgdesc="Background images and data for GNOME"
-url="https://gitlab.gnome.org/GNOME/gnome-backgrounds"
+pkgdesc='Background images and data for GNOME'
+url='https://gitlab.gnome.org/GNOME/gnome-backgrounds'
arch=(any)
+depends=(webp-pixbuf-loader)
+makedepends=(git glib2 meson)
provides=(gnome-backgrounds)
conflicts=(gnome-backgrounds)
-makedepends=('git' 'glib2' 'meson')
-license=(GPL)
-groups=(gnome)
-source=("git+https://gitlab.gnome.org/GNOME/gnome-backgrounds.git")
-sha256sums=('SKIP')
+license=(CCPL:by-sa)
+source=('git+https://gitlab.gnome.org/GNOME/gnome-backgrounds.git')
+b2sums=('SKIP')
pkgver() {
- cd gnome-backgrounds
- git describe --tags | sed 's/-/+/g'
+ cd gnome-backgrounds
+ git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
- arch-meson gnome-backgrounds build
- ninja -C build
+ arch-meson gnome-backgrounds build
+ meson compile -C build
}
check() {
- meson test -C build
+ meson test -C build --print-errorlogs
}
package() {
- DESTDIR="$pkgdir" meson install -C build
+ meson install -C build --destdir "${pkgdir}"
}
-
-# vim:set sw=2 et: