summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCassandra Watergate2022-04-27 17:13:46 -0700
committerCassandra Watergate2022-04-27 17:13:46 -0700
commit15b4a598f4a7c2ce8f9f58ce9551c2ab3ea1f6c4 (patch)
tree0204585719a0e3ea593e5e489b7e2914b968dad6
downloadaur-15b4a598f4a7c2ce8f9f58ce9551c2ab3ea1f6c4.tar.gz
Initial Commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD28
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7480a090ffcd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = gnome-backgrounds-macos-git
+ pkgdesc = Background images for the GNOME desktop from MacOS
+ pkgver = r6.0cfa363
+ pkgrel = 0
+ url = https://github.com/saltedcoffii/gnome-backgrounds-macos
+ arch = any
+ license = CCPL:by-sa
+ license = GPL3 or any later version
+ makedepends = glib2
+ makedepends = meson>=0.50.0
+ makedepends = curl
+ provides = gnome-backgrounds
+ provides = gnome-backgrounds-git
+ provides = gnome-backgrounds-macos
+ conflicts = gnome-backgrounds-macos
+ source = git+https://github.com/saltedcoffii/$pkgname.git
+ sha256sums = SKIP
+
+pkgname = gnome-backgrounds-macos-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..25099b03ee75
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Cassandra Watergate (saltedcoffii) <cassandrawatergate@outlook.com>
+
+pkgname=gnome-backgrounds-macos-git
+pkgver=r6.0cfa363
+pkgrel=0
+pkgdesc="Background images for the GNOME desktop from MacOS"
+url="https://github.com/saltedcoffii/gnome-backgrounds-macos"
+arch=(any)
+makedepends=('glib2' 'meson>=0.50.0' 'curl')
+license=('CCPL:by-sa' 'GPL3 or any later version')
+provides=('gnome-backgrounds' 'gnome-backgrounds-git' 'gnome-backgrounds-macos')
+conflicts=('gnome-backgrounds-macos')
+source=('git+https://github.com/saltedcoffii/$pkgname.git')
+sha256sums=('SKIP')
+
+build() {
+ $srcdir/$pkgname-$pkgver/download-backgrounds.sh
+ arch-meson $pkgname-$pkgver build
+ meson compile -C build
+}
+
+check() {
+ meson test -C build --print-errorlogs
+}
+
+package() {
+ meson install -C build --destdir "$pkgdir"
+}