summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2021-03-18 14:29:07 -0600
committerMark Wagie2021-03-18 14:29:07 -0600
commit86b0f24c66e12b14ad756ad2f87d1ffdd956c511 (patch)
tree7edaff195a216147734d96e65997c1ed823b8341
downloadaur-86b0f24c66e12b14ad756ad2f87d1ffdd956c511.tar.gz
initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD41
3 files changed, 67 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..eb93e4dfdb55
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = gnome-bluetooth-battery-indicator-git
+ pkgdesc = Gnome-Shell extension displaying battery percentage for bluetooth devices
+ pkgver = r17.aead0c9
+ pkgrel = 1
+ url = https://github.com/MichalW/gnome-bluetooth-battery-indicator
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = gnome-shell
+ depends = python-pybluez
+ provides = gnome-bluetooth-battery-indicator
+ conflicts = gnome-bluetooth-battery-indicator
+ source = git+https://github.com/MichalW/gnome-bluetooth-battery-indicator.git
+ source = git+https://github.com/TheWeirdDev/Bluetooth_Headset_Battery_Level.git
+ sha256sums = SKIP
+ sha256sums = SKIP
+
+pkgname = gnome-bluetooth-battery-indicator-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..4dab8d6386e3
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+# Ignore everything
+*
+
+# But not these files...
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..81b719f35eec
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
+pkgname=gnome-bluetooth-battery-indicator-git
+pkgver=r17.aead0c9
+pkgrel=1
+pkgdesc="Gnome-Shell extension displaying battery percentage for bluetooth devices"
+arch=('any')
+url="https://github.com/MichalW/gnome-bluetooth-battery-indicator"
+license=('GPL3')
+depends=('gnome-shell' 'python-pybluez')
+makedepends=('git')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=('git+https://github.com/MichalW/gnome-bluetooth-battery-indicator.git'
+ 'git+https://github.com/TheWeirdDev/Bluetooth_Headset_Battery_Level.git')
+sha256sums=('SKIP'
+ 'SKIP')
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd "$srcdir/${pkgname%-git}"
+ git submodule init
+ git config submodule.Bluetooth_Headset_Battery_Level.url \
+ "$srcdir/Bluetooth_Headset_Battery_Level"
+ git submodule update
+}
+
+package() {
+ _uuid='bluetooth-battery@michalw.github.com'
+
+ cd "$srcdir/${pkgname%-git}"
+ install -d "$pkgdir/usr/share/gnome-shell/extensions/$_uuid"
+ cp -r * "$pkgdir/usr/share/gnome-shell/extensions/$_uuid"
+
+ # Remove unnecessary files
+ find "$pkgdir/usr/share/gnome-shell/extensions/$_uuid/Bluetooth_Headset_Battery_Level" \
+ -type f ! -name '*.py' -delete
+}