summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKevin Majewski2021-01-16 16:08:37 +0100
committerKevin Majewski2021-01-16 16:08:37 +0100
commitb7ea4921a0fdb7c7469b8e3e9e197b87ef6b0438 (patch)
tree5a92df6e894d08daea347f7c456544008ae2fc28
parent82a8617356849c4f709bd08e65851640d7c151da (diff)
downloadaur-b7ea4921a0fdb7c7469b8e3e9e197b87ef6b0438.tar.gz
Sync with arch
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD22
2 files changed, 24 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cc73ca81723b..0cb6ee391d0f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = gnome-boxes-git
pkgdesc = Simple GNOME application to access remote or virtual systems
- pkgver = 3.37.90+45+g1593f6fd
+ pkgver = 3.37.90+158+g478d3c69
pkgrel = 1
url = https://wiki.gnome.org/Apps/Boxes
arch = x86_64
@@ -12,28 +12,30 @@ pkgbase = gnome-boxes-git
makedepends = spice-protocol
makedepends = vala
depends = cdrtools
+ depends = edk2-ovmf
+ depends = freerdp
+ depends = gtksourceview4
depends = gtk-vnc
depends = libarchive
depends = libgudev
+ depends = libhandy
depends = libosinfo
depends = libsecret
depends = libvirt-glib
depends = mtools
depends = qemu
depends = spice-gtk
- depends = tracker
+ depends = tracker3
depends = webkit2gtk
- depends = freerdp
- depends = libhandy
- depends = gtksourceview4
provides = gnome-boxes
conflicts = gnome-boxes
source = git+https://gitlab.gnome.org/GNOME/gnome-boxes.git
source = git+https://gitlab.gnome.org/GNOME/gtk-frdp.git
+ source = git+https://gitlab.gnome.org/GNOME/libhandy.git
source = git+https://gitlab.gnome.org/felipeborges/libovf-glib.git
- sha512sums = SKIP
- sha512sums = SKIP
- sha512sums = SKIP
+ b2sums = SKIP
+ b2sums = SKIP
+ b2sums = SKIP
+ b2sums = SKIP
pkgname = gnome-boxes-git
-
diff --git a/PKGBUILD b/PKGBUILD
index e376c8a933df..2713b4b611df 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,24 @@
pkgname=gnome-boxes-git
_pkgname=gnome-boxes
-pkgver=3.37.90+45+g1593f6fd
+pkgver=3.37.90+158+g478d3c69
pkgrel=1
pkgdesc="Simple GNOME application to access remote or virtual systems"
-arch=('x86_64')
+arch=(x86_64)
url="https://wiki.gnome.org/Apps/Boxes"
-license=('LGPL')
-depends=('cdrtools' 'gtk-vnc' 'libarchive' 'libgudev' 'libosinfo' 'libsecret'
- 'libvirt-glib' 'mtools' 'qemu' 'spice-gtk' 'tracker' 'webkit2gtk' 'freerdp' 'libhandy' 'gtksourceview4')
+license=(LGPL)
+depends=('cdrtools' 'edk2-ovmf' 'freerdp' 'gtksourceview4' 'gtk-vnc' 'libarchive' 'libgudev' 'libhandy' 'libosinfo'
+ 'libsecret' 'libvirt-glib' 'mtools' 'qemu' 'spice-gtk' 'tracker3' 'webkit2gtk')
makedepends=('git' 'gobject-introspection' 'yelp-tools' 'meson' 'spice-protocol' 'vala')
provides=('gnome-boxes')
conflicts=('gnome-boxes')
source=("git+https://gitlab.gnome.org/GNOME/gnome-boxes.git"
"git+https://gitlab.gnome.org/GNOME/gtk-frdp.git"
+ "git+https://gitlab.gnome.org/GNOME/libhandy.git"
"git+https://gitlab.gnome.org/felipeborges/libovf-glib.git")
-sha512sums=('SKIP'
- 'SKIP'
- 'SKIP')
+b2sums=('SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP')
pkgver() {
cd $_pkgname
@@ -25,15 +27,17 @@ pkgver() {
prepare() {
cd $_pkgname
+
git submodule init
git submodule set-url subprojects/gtk-frdp "$srcdir/gtk-frdp"
+ git submodule set-url subprojects/libhandy "$srcdir/libhandy"
git submodule set-url subprojects/libovf-glib "$srcdir/libovf-glib"
git submodule update
}
build() {
arch-meson $_pkgname build
- ninja -C build
+ meson compile -C build
}
check() {