summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKevin Majewski2020-03-09 10:39:45 +0100
committerKevin Majewski2020-03-09 10:39:45 +0100
commitd06911cae6405489f8e26edff369537294d78704 (patch)
tree6416d16fe9af63479d53d68df066315fcff1fe58
downloadaur-d06911cae6405489f8e26edff369537294d78704.tar.gz
Initial commit
-rw-r--r--.SRCINFO37
-rw-r--r--PKGBUILD45
2 files changed, 82 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..51d70aeea301
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,37 @@
+pkgbase = gnome-boxes-git
+ pkgdesc = Simple GNOME application to access remote or virtual systems
+ pkgver = 3.35.90+56+gcd589137
+ pkgrel = 1
+ url = https://wiki.gnome.org/Apps/Boxes
+ arch = x86_64
+ license = LGPL
+ makedepends = git
+ makedepends = gobject-introspection
+ makedepends = yelp-tools
+ makedepends = meson
+ makedepends = spice-protocol
+ makedepends = vala
+ depends = cdrtools
+ depends = gtk-vnc
+ depends = libarchive
+ depends = libgudev
+ depends = libosinfo
+ depends = libsecret
+ depends = libvirt-glib
+ depends = mtools
+ depends = qemu
+ depends = spice-gtk
+ depends = tracker
+ depends = webkit2gtk
+ depends = freerdp
+ provides = gnome-boxes
+ conflicts = gnome-boxes
+ source = git+https://gitlab.gnome.org/GNOME/gnome-boxes.git
+ source = git+https://gitlab.gnome.org/GNOME/gtk-frdp.git
+ source = git+https://gitlab.gnome.org/felipeborges/libovf-glib.git
+ sha512sums = SKIP
+ sha512sums = SKIP
+ sha512sums = SKIP
+
+pkgname = gnome-boxes-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5326befb755b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+pkgname=gnome-boxes-git
+_pkgname=gnome-boxes
+pkgver=3.35.90+56+gcd589137
+pkgrel=1
+pkgdesc="Simple GNOME application to access remote or virtual systems"
+arch=('x86_64')
+url="https://wiki.gnome.org/Apps/Boxes"
+license=('LGPL')
+depends=('cdrtools' 'gtk-vnc' 'libarchive' 'libgudev' 'libosinfo' 'libsecret'
+ 'libvirt-glib' 'mtools' 'qemu' 'spice-gtk' 'tracker' 'webkit2gtk' 'freerdp')
+makedepends=('git' 'gobject-introspection' 'yelp-tools' 'meson' 'spice-protocol' 'vala')
+provides=('gnome-boxes')
+conflicts=('gnome-boxes')
+source=("git+https://gitlab.gnome.org/GNOME/gnome-boxes.git"
+ "git+https://gitlab.gnome.org/GNOME/gtk-frdp.git"
+ "git+https://gitlab.gnome.org/felipeborges/libovf-glib.git")
+sha512sums=('SKIP'
+ 'SKIP'
+ 'SKIP')
+
+pkgver() {
+ cd $_pkgname
+ git describe --tags | sed 's/^v//;s/-/+/g'
+}
+
+prepare() {
+ cd $_pkgname
+ git submodule init
+ git submodule set-url subprojects/gtk-frdp "$srcdir/gtk-frdp"
+ git submodule set-url subprojects/libovf-glib "$srcdir/libovf-glib"
+ git submodule update
+}
+
+build() {
+ arch-meson $_pkgname build
+ ninja -C build
+}
+
+check() {
+ meson test -C build --print-errorlogs
+}
+
+package() {
+ DESTDIR="$pkgdir" meson install -C build
+}