summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKevin Majewski2020-03-09 18:04:20 +0100
committerKevin Majewski2020-03-09 18:04:20 +0100
commitecbea744c6d8b4d99bcd5d244e41a1850e9f6c88 (patch)
tree9857730aed61f1117903564c0d91ca885347fd6f
downloadaur-ecbea744c6d8b4d99bcd5d244e41a1850e9f6c88.tar.gz
Initial commit
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD35
2 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..564972c8d378
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = gnome-calendar-git
+ pkgdesc = Simple and beautiful calendar application designed to perfectly fit the GNOME desktop
+ pkgver = 3.36.0+2+g90233510
+ pkgrel = 1
+ url = https://wiki.gnome.org/Apps/Calendar
+ arch = x86_64
+ license = GPL
+ makedepends = python
+ makedepends = appstream-glib
+ makedepends = git
+ makedepends = meson
+ depends = evolution-data-server
+ depends = gsettings-desktop-schemas
+ depends = gnome-control-center
+ depends = libdazzle
+ optdepends = evolution: ICS file import
+ provides = gnome-calendar
+ conflicts = gnome-calendar
+ source = git+https://gitlab.gnome.org/GNOME/gnome-calendar.git
+ sha512sums = SKIP
+
+pkgname = gnome-calendar-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..72d4751c731d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+pkgname=gnome-calendar-git
+_pkgname=gnome-calendar
+pkgver=3.36.0+2+g90233510
+pkgrel=1
+pkgdesc="Simple and beautiful calendar application designed to perfectly fit the GNOME desktop"
+url="https://wiki.gnome.org/Apps/Calendar"
+arch=(x86_64)
+license=(GPL)
+depends=('evolution-data-server' 'gsettings-desktop-schemas' 'gnome-control-center' 'libdazzle')
+makedepends=('python' 'appstream-glib' 'git' 'meson')
+optdepends=('evolution: ICS file import')
+provides=('gnome-calendar')
+conflicts=('gnome-calendar')
+source=("git+https://gitlab.gnome.org/GNOME/gnome-calendar.git")
+sha512sums=('SKIP')
+
+pkgver() {
+ cd $_pkgname
+ git describe --tags | sed 's/-/+/g'
+}
+
+build() {
+ arch-meson $_pkgname build
+ ninja -C build
+}
+
+check() {
+ meson test -C build --print-errorlogs
+}
+
+package() {
+ DESTDIR="$pkgdir" meson install -C build
+}
+
+# vim:set ts=2 sw=2 et: