summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSam Burgos2021-12-23 11:38:58 -0600
committerSam Burgos2021-12-23 11:38:58 -0600
commit671162a5054d654eeecac0b8de500d0a5cda1a38 (patch)
treecb87dcbf0b2af08cf4d838bd7b1b7314183cf758
parent01ea95410323c36a0073ca1a1273a66ba242a168 (diff)
downloadaur-671162a5054d654eeecac0b8de500d0a5cda1a38.tar.gz
updated to version 41.2 and merged options from upstream
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD12
2 files changed, 6 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0d9683b178f6..76211056ec1e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -9,8 +9,6 @@ pkgbase = gnome-calendar-linuxmint
makedepends = appstream-glib
makedepends = git
makedepends = meson
- depends = cinnamon
- depends = cinnamon-control-center
depends = evolution-data-server
depends = geoclue
depends = gnome-online-accounts
@@ -22,7 +20,7 @@ pkgbase = gnome-calendar-linuxmint
optdepends = evolution: ICS file import
provides = gnome-calendar
conflicts = gnome-calendar
- source = git+https://gitlab.gnome.org/GNOME/gnome-calendar.git#commit=59ad10ba3aaed69c96c5e7f710b3f2c6b35131ae
+ source = git+https://gitlab.gnome.org/GNOME/gnome-calendar.git#commit=deb9ff18302457b91fb8013f98880c8e3a548c19
source = linuxmint_gcal_window.patch
source = linuxmint_gcal_new_calendar_page.patch
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 4e42aad1cc34..065ac19b87db 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,8 +9,6 @@ arch=(x86_64)
url=https://wiki.gnome.org/Apps/Calendar
license=(GPL)
depends=(
- cinnamon
- cinnamon-control-center
evolution-data-server
geoclue
gnome-online-accounts
@@ -31,7 +29,7 @@ makedepends=(
provides=(${_pkgname})
conflicts=(${_pkgname})
groups=(gnome)
-_commit=59ad10ba3aaed69c96c5e7f710b3f2c6b35131ae # tags/41.1^0
+_commit=deb9ff18302457b91fb8013f98880c8e3a548c19 # tags/41.2^0
source=(
"git+https://gitlab.gnome.org/GNOME/gnome-calendar.git#commit=$_commit"
"linuxmint_gcal_window.patch"
@@ -43,7 +41,7 @@ sha256sums=('SKIP'
pkgver() {
cd $_pkgname
- git describe --tags | sed 's/-/+/g'
+ git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
}
prepare() {
@@ -58,8 +56,8 @@ prepare() {
}
build() {
- arch-meson $_pkgname build
- ninja -C build
+ arch-meson $pkgname build
+ meson compile -C build
}
check() {
@@ -67,5 +65,5 @@ check() {
}
package() {
- DESTDIR="$pkgdir" meson install -C build
+ meson install -C build --destdir "$pkgdir"
}