summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSam Burgos2018-09-21 11:26:14 -0600
committerSam Burgos2018-09-21 11:26:14 -0600
commit9597ab0cd27014d92a821ec35d465ce26275f1fa (patch)
treebe69b9d5cd398d8ac84d456c6fc1a20f8ba66d09
parent6c4ed229a0060fb7a6ceca43c17a18cc2e69129b (diff)
downloadaur-9597ab0cd27014d92a821ec35d465ce26275f1fa.tar.gz
updated gnome-calendar to version 3.30.0
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD20
2 files changed, 16 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6ecd60a62a92..d36604c69b28 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = gnome-calendar-linuxmint
pkgdesc = Simple and beautiful calendar application designed to perfectly fit the GNOME desktop. With Linux Mint patches
- pkgver = 3.28.2
- pkgrel = 2
+ pkgver = 3.30.0
+ pkgrel = 1
url = https://wiki.gnome.org/Apps/Calendar
arch = x86_64
license = GPL
@@ -16,7 +16,7 @@ pkgbase = gnome-calendar-linuxmint
depends = libdazzle
provides = gnome-calendar
conflicts = gnome-calendar
- source = git+https://gitlab.gnome.org/GNOME/gnome-calendar.git#commit=c4d1f984758e77787ef97b71fe2dede8477809c2
+ source = git+https://gitlab.gnome.org/GNOME/gnome-calendar.git#commit=63ed4c48c84291ca70c747d6078090f8263088bf
source = null-icaltime.diff
source = add_cinnamon_settings_online_support.patch
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index e4ad89e8cbcc..915e3d29bb44 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
pkgname=gnome-calendar-linuxmint
_pkgname=gnome-calendar
-pkgver=3.28.2
-pkgrel=2
+pkgver=3.30.0
+pkgrel=1
pkgdesc="Simple and beautiful calendar application designed to perfectly fit the GNOME desktop. With Linux Mint patches"
url="https://wiki.gnome.org/Apps/Calendar"
arch=('x86_64')
@@ -19,7 +19,7 @@ makedepends=('appstream-glib'
'python')
provides=("${_pkgname}")
conflicts=("${_pkgname}")
-_commit=c4d1f984758e77787ef97b71fe2dede8477809c2 # tags/3.28.2^0
+_commit=63ed4c48c84291ca70c747d6078090f8263088bf # tags/3.30.0^0
source=("git+https://gitlab.gnome.org/GNOME/gnome-calendar.git#commit=$_commit"
"null-icaltime.diff"
"add_cinnamon_settings_online_support.patch")
@@ -27,6 +27,11 @@ sha256sums=('SKIP'
'c1aa738a4ff275f725d0aa5406312600503b2b59270448a9e6b30b82a924dc27'
'2445f754a044dd1ccb8c948b5d5b43248b61ec3570fc76416f74148abc5abf4d')
+pkgver() {
+ cd $pkgname
+ git describe --tags | sed 's/-/+/g'
+}
+
prepare() {
cd $_pkgname
#Set datetime to NULL in case there is no available date
@@ -37,15 +42,16 @@ prepare() {
}
build() {
- arch-meson "${_pkgname}" build -D gtk_doc=true
+ arch-meson $_pkgname build \
+ --buildtype=debugoptimized \
+ -D documentation=true
ninja -C build
}
check() {
- cd build
- meson test
+ meson test -C build
}
package() {
- DESTDIR="$pkgdir" ninja -C build install
+ DESTDIR="$pkgdir" meson install -C build
}