summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSam Burgos2019-05-28 16:31:19 -0600
committerSam Burgos2019-05-28 16:31:19 -0600
commit98b6ed25fba537aa0936d5cef729509b092328e6 (patch)
treee2824a68e9fac560b687ce2ece46608547559614
parent731628b0f09b71e8062295faf0555c38bdf62d90 (diff)
downloadaur-98b6ed25fba537aa0936d5cef729509b092328e6.tar.gz
updated version of gnome-calendar
-rw-r--r--PKGBUILD69
1 files changed, 38 insertions, 31 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 58dd1940e6f0..84cf69edaa09 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,29 +2,38 @@
pkgname=gnome-calendar-linuxmint
_pkgname=gnome-calendar
-pkgver=3.32.0
-pkgrel=3
-pkgdesc="Simple and beautiful calendar application designed to perfectly fit the GNOME desktop. With Linux Mint patches"
-url="https://wiki.gnome.org/Apps/Calendar"
-arch=('x86_64')
-license=('GPL')
-depends=('evolution-data-server'
- 'geoclue2'
- 'gsettings-desktop-schemas'
- 'libdazzle')
-makedepends=('appstream-glib'
- 'evolution'
- 'git'
- 'gtk-doc'
- 'meson'
- 'python')
-provides=("${_pkgname}")
-conflicts=("${_pkgname}")
-_commit=643622069d939529eafb7aa94d95905795e6fb94 # master
-source=("git+https://gitlab.gnome.org/GNOME/gnome-calendar.git#commit=$_commit"
- "null-icaltime.diff"
- "add_cinnamon_settings_online_support.patch"
- "set_window_icon_name.patch")
+pkgver=3.32.2
+pkgrel=1
+pkgdesc='Simple and beautiful calendar application designed to perfectly fit the GNOME desktop. With Linux Mint patches'
+arch=(x86_64)
+url=https://wiki.gnome.org/Apps/Calendar
+license=(GPL)
+depends=(
+ evolution-data-server
+ geoclue2
+ gsettings-desktop-schemas
+ libdazzle
+)
+optdepends=(
+ 'evolution: ICS file import'
+)
+makedepends=(
+ appstream-glib
+ git
+ gtk-doc
+ meson
+ python
+)
+provides=(${_pkgname})
+conflicts=(${_pkgname})
+groups=(gnome)
+_commit=366f6f7aadebcb5bb61dfa6a1416384f90a3a4cd # tags/3.32.2^0
+source=(
+ "git+https://gitlab.gnome.org/GNOME/gnome-calendar.git#commit=$_commit"
+ "null-icaltime.diff"
+ "add_cinnamon_settings_online_support.patch"
+ "set_window_icon_name.patch"
+)
sha256sums=('SKIP'
'c1aa738a4ff275f725d0aa5406312600503b2b59270448a9e6b30b82a924dc27'
'2445f754a044dd1ccb8c948b5d5b43248b61ec3570fc76416f74148abc5abf4d'
@@ -39,23 +48,21 @@ prepare() {
cd $_pkgname
# Set datetime to NULL in case there is no available date
patch -Np1 -i ../null-icaltime.diff
-
- # Add support so that gnome-calendar can call this when run within Cinnamon by calling cinnamon-settings online-accounts
+
+ # Add support so that gnome-calendar run within Cinnamon by calling cinnamon-settings online-accounts
patch -Np0 -i ../add_cinnamon_settings_online_support.patch
-
+
# Fix: Set window icon name
- patch -Np0 -i ../set_window_icon_name.patch
+ patch -Np0 -i ../set_window_icon_name.patch
}
build() {
- arch-meson $_pkgname build \
- --buildtype=debugoptimized \
- -D documentation=true
+ arch-meson $pkgname build -D documentation=true
ninja -C build
}
check() {
- meson test -C build
+ meson test -C build --print-errorlogs
}
package() {