summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Filion2021-01-19 12:05:11 -0500
committerMartin Filion2021-01-19 12:05:11 -0500
commitb93aec11d9a0b517e193746e52a485c02c15fb44 (patch)
tree801bf7d3600ae6ce10e2c6a25f41779c6efc6016
parentdcac8ad08ece4e820e1e9f0d3619a3723d62a179 (diff)
downloadaur-b93aec11d9a0b517e193746e52a485c02c15fb44.tar.gz
create patch, and made sure to download from latest master branch
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD33
-rw-r--r--inkscape_command.patch11
3 files changed, 39 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index af537a7d6b27..5cc090cd8d58 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,18 @@
-# Generated by mksrcinfo v8
-# Mon Oct 24 15:51:02 UTC 2016
pkgbase = gnome-colors-icon-theme
pkgdesc = GNOME-Colors icon theme
- pkgver = 0.r217.g8689d1d
- pkgrel = 2
- epoch = 1
+ pkgver = 5.5.1
+ pkgrel = 3
url = https://github.com/gnome-colors/gnome-colors
arch = any
license = GPL2
makedepends = git
makedepends = inkscape
+ makedepends = imagemagick
+ makedepends = gnome-icon-theme
+ makedepends = gnome-icon-theme-symbolic
conflicts = gnome-colors-icon-theme-extras
replaces = gnome-colors-icon-theme-extras
- source = git://github.com/gnome-colors/gnome-colors.git#commit=8689d1d
+ source = git://github.com/gnome-colors/gnome-colors
sha256sums = SKIP
pkgname = gnome-colors-icon-theme
diff --git a/PKGBUILD b/PKGBUILD
index 0be5c9a3de9c..4733f3035029 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,5 @@
-# Maintainer: Christian Hesse <arch@eworm.de>
+# Maintainer: Martin Filion <Mordillo98@gmail.com>
+# Contributor: Christian Hesse <arch@eworm.de>
# Contributor: BlackICE <manfredi at gmail.com>
# Contributor: jsteel <jsteel at aur.archlinux.org>
# Contributor: Arkham <arkham at archlinux dot us>
@@ -6,29 +7,39 @@
# Contributor: Marius <marius at matamare dot ro>
pkgname=gnome-colors-icon-theme
-epoch=1
-pkgver=0.r217.g8689d1d
-_commit=8689d1d
-pkgrel=2
+pkgname_link=gnome-colors-icon-theme
+pkgver=5.5.1
+pkgrel=3
pkgdesc='GNOME-Colors icon theme'
arch=('any')
url='https://github.com/gnome-colors/gnome-colors'
license=('GPL2')
conflicts=('gnome-colors-icon-theme-extras')
replaces=('gnome-colors-icon-theme-extras')
-makedepends=('git' 'inkscape')
-source=("git://github.com/gnome-colors/gnome-colors.git#commit=${_commit}")
+makedepends=('git' 'inkscape' 'imagemagick' 'gnome-icon-theme' 'gnome-icon-theme-symbolic')
+source=("git://github.com/gnome-colors/gnome-colors")
sha256sums=('SKIP')
+prepare() {
+
+ cd "${srcdir}/gnome-colors/gnome-colors/"
+ patch -i ../../../inkscape_command.patch
+
+}
+
build() {
- cd "${srcdir}/gnome-colors/gnome-colors/"
- make
+ cd "${srcdir}/gnome-colors/gnome-colors/"
+
+ make
+
}
package() {
- cd "${srcdir}/gnome-colors/gnome-colors/"
- make DESTDIR="${pkgdir}"/ install
+ cd "${srcdir}/gnome-colors/gnome-colors/"
+
+ make DESTDIR="${pkgdir}"/ install
+
}
diff --git a/inkscape_command.patch b/inkscape_command.patch
new file mode 100644
index 000000000000..0ff4cff73edc
--- /dev/null
+++ b/inkscape_command.patch
@@ -0,0 +1,11 @@
+--- Makefile 2021-01-19 11:24:16.286931801 -0500
++++ src/gnome-colors/gnome-colors/Makefile 2021-01-19 11:05:31.733635017 -0500
+@@ -99,7 +99,7 @@
+ define png_template
+ $(1)/$(2).png: src/$(2).svg themes/$(1)
+ @if test ! -d $$(dir $$@); then mkdir -p $$(dir $$@); echo "mkdir -p $$(dir $$@)"; fi
++ sed "$$($(1)_$(3)_sed)" $$< | inkscape /dev/stdin --export-filename="$$(CURDIR)/$$@"
+- sed "$$($(1)_$(3)_sed)" $$< | inkscape --without-gui -f /dev/stdin -e "$$(CURDIR)/$$@"
+ endef
+
+ define svg_template