summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRafael Ferreira2015-06-20 11:57:39 -0300
committerRafael Ferreira2015-06-20 11:57:39 -0300
commit9fd243b2412c30a0052edfca15531af54e7d9532 (patch)
tree7b177ca3b8914718418f154e53b959b9a00f5b45
downloadaur-9fd243b2412c30a0052edfca15531af54e7d9532.tar.gz
Initial import
-rw-r--r--.SRCINFO29
-rw-r--r--PKGBUILD52
-rw-r--r--gnome-commander.install22
3 files changed, 103 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..dd5205802c87
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,29 @@
+pkgbase = gnome-commander-git
+ pkgdesc = A graphical two-pane filemanager for GNOME
+ pkgver = 1.4.0.24.g7ee4460
+ pkgrel = 1
+ url = http://gcmd.github.io/
+ install = gnome-commander.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = perlxml
+ makedepends = gnome-doc-utils
+ makedepends = chmlib
+ makedepends = gnome-common
+ makedepends = intltool
+ depends = libgnomeui
+ depends = exiv2
+ depends = taglib
+ depends = libgsf
+ depends = python2
+ depends = poppler
+ depends = libunique
+ provides = gnome-commander
+ conflicts = gnome-commander
+ options = !libtool
+ source = git://git.gnome.org/gnome-commander
+ md5sums = SKIP
+
+pkgname = gnome-commander-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a359ba791727
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,52 @@
+# Maintainer: Rafael Ferreira <rafael.f.f1@gmail.com>
+# Contributor: Thomas Jost <schnouki@schnouki.net>
+# Contributor: Alexander 'hatred' Drozdov <adrozdoff@gmail.com>
+
+_name=gnome-commander
+pkgname=$_name-git
+pkgver=1.4.0.24.g7ee4460
+pkgrel=1
+pkgdesc="A graphical two-pane filemanager for GNOME"
+arch=('i686' 'x86_64')
+url="http://gcmd.github.io/"
+license=('GPL')
+depends=('libgnomeui' 'exiv2' 'taglib' 'libgsf' 'python2' 'poppler' 'libunique')
+makedepends=('perlxml' 'gnome-doc-utils' 'chmlib' 'gnome-common' 'intltool')
+options=(!libtool)
+install=$_name.install
+provides=($_name)
+conflicts=($_name)
+source=(git://git.gnome.org/$_name)
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_name"
+ git describe --tags | sed -e 's/-/./g'
+}
+
+build() {
+ cd "$srcdir/$_name"
+
+ # python2 fix
+ for file in doc/*/gnome-commander.xml; do
+ sed -i 's_#!/usr/bin/env python_#!/usr/bin/env python2_' $file
+ done
+ export PYTHON=python2
+
+ export CFLAGS="$CFLAGS -fno-strict-aliasing"
+ ./autogen.sh --prefix=/usr --libdir=/usr/lib --sysconfdir=/etc \
+ --localstatedir=/var --disable-scrollkeeper --enable-python
+
+ make
+}
+
+package() {
+ cd "$srcdir/$_name"
+
+ make GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1 DESTDIR="$pkgdir" install
+
+ mkdir -p "$pkgdir"/usr/share/gconf/schemas
+ gconf-merge-schema "$pkgdir"/usr/share/gconf/schemas/${pkgname}.schemas \
+ "$pkgdir"/etc/gconf/schemas/*.schemas
+ rm -f "$pkgdir"/etc/gconf/schemas/*.schemas
+}
diff --git a/gnome-commander.install b/gnome-commander.install
new file mode 100644
index 000000000000..24cfe228ea7a
--- /dev/null
+++ b/gnome-commander.install
@@ -0,0 +1,22 @@
+pkgname=gnome-commander-git
+
+post_install() {
+ usr/sbin/gconfpkg --install ${pkgname}
+ update-desktop-database -q
+}
+
+pre_upgrade() {
+ pre_remove $1
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+pre_remove() {
+ usr/sbin/gconfpkg --uninstall ${pkgname}
+}
+
+post_remove() {
+ update-desktop-database -q
+}