summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLubosz Sarnecki2015-07-13 16:10:53 +0200
committerLubosz Sarnecki2015-07-13 16:14:15 +0200
commit3eb6f1eb92b77dd11ce1d0cf98c7ef662f9f666b (patch)
treebb9912619fd5bc46b3d8ab4da47cc33ef61e680d
downloadaur-3eb6f1eb92b77dd11ce1d0cf98c7ef662f9f666b.tar.gz
import from aur3 and update version
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD37
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9274237fedc4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = gnome-common-git
+ pkgdesc = Common development macros for GNOME
+ pkgver = 3.14.0.r12.4363223
+ pkgrel = 1
+ url = http://www.gnome.org
+ arch = any
+ license = GPL
+ makedepends = git
+ provides = gnome-common
+ conflicts = gnome-common
+ source = git://git.gnome.org/gnome-common
+ sha256sums = SKIP
+
+pkgname = gnome-common-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fb05786c914b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: alucryd <alucryd at gmail dot com>
+# Contributor: L42y <423300 at gmail dot com>
+# Contributor: teddy_beer_maniac <teddy_beer_maniac at wp dot pl>
+
+pkgname=gnome-common-git
+pkgver=3.14.0.r12.4363223
+pkgrel=1
+pkgdesc="Common development macros for GNOME"
+arch=('any')
+url="http://www.gnome.org"
+license=('GPL')
+makedepends=('git')
+provides=("${pkgname%-*}")
+conflicts=("${pkgname%-*}")
+source=("git://git.gnome.org/${pkgname%-*}")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd ${pkgname%-*}
+
+ printf "%s" "$(git describe --tags | sed 's/-/.r/; s/-g/./')"
+}
+
+build() {
+ cd ${pkgname%-*}
+
+ ./autogen.sh --prefix='/usr'
+ make
+}
+
+package() {
+ cd ${pkgname%-*}
+
+ make DESTDIR="${pkgdir}" install
+}
+
+# vim: ts=2 sw=2 et: