summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilip Goto2019-01-03 22:59:13 +0100
committerPhilip Goto2019-01-03 22:59:13 +0100
commit3039d2d40673b489a4bb560d4d0319466d635d98 (patch)
tree70bc9b0997f15620a6e937cfa3d40b461c1c1ff3
downloadaur-3039d2d40673b489a4bb560d4d0319466d635d98.tar.gz
Initialize package
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD36
2 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..83b4acab27b0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+pkgbase = gnome-contacts-git
+ pkgdesc = Contacts Manager for GNOME
+ pkgver = 3.31.3.r14.g93ca1c6
+ pkgrel = 1
+ url = https://wiki.gnome.org/Apps/Contacts
+ arch = x86_64
+ groups = gnome
+ license = GPL2
+ makedepends = vala
+ makedepends = gobject-introspection
+ makedepends = git
+ makedepends = meson
+ makedepends = libhandy
+ depends = gtk3
+ depends = folks
+ depends = gnome-desktop
+ depends = dconf
+ depends = gnome-online-accounts
+ depends = libgee
+ depends = cheese
+ depends = libhandy
+ provides = gnome-contacts
+ conflicts = gnome-contacts
+ source = git+https://gitlab.gnome.org/GNOME/gnome-contacts.git
+ sha256sums = SKIP
+
+pkgname = gnome-contacts-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..580a169092b1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Philip Goto <philip.goto@gmail.com>
+# Contributor: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
+# Contributor: Ionut Biru <ibiru@archlinux.org>
+
+pkgname=gnome-contacts-git
+pkgver=3.31.3.r14.g93ca1c6
+pkgrel=1
+pkgdesc="Contacts Manager for GNOME"
+url="https://wiki.gnome.org/Apps/Contacts"
+arch=(x86_64)
+license=(GPL2)
+depends=(gtk3 folks gnome-desktop dconf gnome-online-accounts libgee cheese libhandy)
+makedepends=(vala gobject-introspection git meson libhandy)
+groups=(gnome)
+conflicts=(gnome-contacts)
+provides=(gnome-contacts)
+source=("git+https://gitlab.gnome.org/GNOME/gnome-contacts.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd gnome-contacts
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ arch-meson gnome-contacts build
+ ninja -C build
+}
+
+check() {
+ meson test -C build
+}
+
+package() {
+ DESTDIR="$pkgdir" meson install -C build
+} \ No newline at end of file