summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorworkonfire2021-03-21 17:18:34 +0100
committerworkonfire2021-03-21 17:18:34 +0100
commit910972a908a279be0f860e480c1999b4122c6c8f (patch)
tree0d4c78519dcee7031020ecc2075399715e814f2c
downloadaur-910972a908a279be0f860e480c1999b4122c6c8f.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD23
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f58ce3c7f9e4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = gnome-dark-apps-git
+ pkgdesc = Per application dark theme on demand.
+ pkgver = r4.7d002aa
+ pkgrel = 1
+ url = https://workonfi.re
+ arch = any
+ license = GPL
+ depends = xdotool
+ provides = gnome-dark-apps
+ conflicts = gnome-dark-apps
+ source = gnome-dark-apps-git::git+https://github.com/workonfire/gnome-dark-apps.git
+ md5sums = SKIP
+
+pkgname = gnome-dark-apps-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..55db57b8ab18
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+pkgname=gnome-dark-apps-git
+pkgver=r4.7d002aa
+pkgrel=1
+pkgdesc="Per application dark theme on demand."
+arch=('any')
+url="https://workonfi.re"
+license=('GPL')
+depends=('xdotool')
+conflicts=('gnome-dark-apps')
+provides=('gnome-dark-apps')
+source=("${pkgname}"::git+https://github.com/workonfire/gnome-dark-apps.git)
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ install -Dm755 "${srcdir}"/"${pkgname}"/theme.sh "${pkgdir}"/usr/bin/dark-theme-toggle
+ install -Dm644 "${srcdir}"/"${pkgname}"/app-list "${pkgdir}"/usr/share/gnome-dark-apps/app-list
+ install -Dm644 "${srcdir}"/"${pkgname}"/LICENSE "${pkgdir}"/usr/share/licenses/"${pkgname}"/LICENSE
+}