summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntonio Rojas2020-03-17 12:49:29 +0000
committerAntonio Rojas2020-03-17 12:49:29 +0000
commit6193f6a03f34912c66032f7e060244d6194ba8ab (patch)
tree99ec5f5d017aa978a4661753ab822111c8f71e98
downloadaur-6193f6a03f34912c66032f7e060244d6194ba8ab.tar.gz
Dropped from repos
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD38
2 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cef7a50a8104
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = gnome-doc-utils
+ pkgdesc = Documentation utilities for Gnome
+ pkgver = 0.20.10+16+gc03cc09
+ pkgrel = 2
+ url = https://www.gnome.org
+ arch = any
+ license = GPL
+ license = LGPL
+ makedepends = intltool
+ makedepends = gnome-common
+ makedepends = git
+ depends = libxslt
+ depends = python2
+ depends = docbook-xml
+ depends = rarian
+ source = git+https://git.gnome.org/browse/gnome-doc-utils#commit=c03cc0963996934e03587af3e351c2bb9dab6b2a
+ sha256sums = SKIP
+
+pkgname = gnome-doc-utils
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1f2acfe96244
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Jan de Groot <jgc@archlinux.org>
+
+pkgname=gnome-doc-utils
+pkgver=0.20.10+16+gc03cc09
+pkgrel=2
+pkgdesc="Documentation utilities for Gnome"
+arch=('any')
+license=('GPL' 'LGPL')
+depends=('libxslt' 'python2' 'docbook-xml' 'rarian')
+makedepends=('intltool' gnome-common git)
+url="https://www.gnome.org"
+_commit=c03cc0963996934e03587af3e351c2bb9dab6b2a # master
+source=("git+https://git.gnome.org/browse/gnome-doc-utils#commit=$_commit")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd $pkgname
+ git describe --tags | sed 's/-/+/g'
+}
+
+prepare() {
+ cd $pkgname
+ rm -f m4/glib-gettext.m4
+ NOCONFIGURE=1 ./autogen.sh
+}
+
+build() {
+ cd "$pkgname"
+ PYTHON=/usr/bin/python2 ./configure --prefix=/usr \
+ --sysconfdir=/etc --mandir=/usr/share/man \
+ --localstatedir=/var --disable-scrollkeeper
+ make
+}
+
+package() {
+ cd "$pkgname"
+ make DESTDIR="$pkgdir" install
+}