summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoricepie2021-11-12 22:38:59 +0800
committericepie2021-11-12 22:38:59 +0800
commit639cf5ae45365a96074f1b57919d622796036b8a (patch)
treea0c4402869891dba422e934044b5556dd622d3b4
downloadaur-639cf5ae45365a96074f1b57919d622796036b8a.tar.gz
init
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD39
2 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d43670509e95
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = gnome-egpu-git
+ pkgdesc = eGPU switcher for GNOME using udev rules
+ pkgver = 0.1.0.9.g16617f5
+ pkgrel = 1
+ url = https://github.com/dangreco/gnome-egpu
+ arch = x86_64
+ license = MIT
+ makedepends = rust
+ makedepends = cargo
+ makedepends = git
+ provides = lsd
+ conflicts = gnome-egpu
+ source = gnome-egpu::git+https://github.com/dangreco/gnome-egpu.git
+ sha256sums = SKIP
+
+pkgname = gnome-egpu-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..51239964d2a0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: icepie <icepie.dev@gmail.com>
+
+pkgname="gnome-egpu-git"
+_pkgname="gnome-egpu"
+pkgver=0.1.0.9.g16617f5
+pkgrel=1
+pkgdesc="eGPU switcher for GNOME using udev rules"
+arch=("x86_64")
+url="https://github.com/dangreco/gnome-egpu"
+license=("MIT")
+depends=()
+optdepends=()
+makedepends=("rust" "cargo" "git")
+provides=("lsd")
+conflicts=("gnome-egpu")
+source=("$_pkgname::git+https://github.com/dangreco/gnome-egpu.git")
+sha256sums=("SKIP")
+
+pkgver() {
+ cd "$_pkgname"
+ echo "$(grep '^version =' Cargo.toml|head -n1|cut -d\" -f2).$(git rev-list --count HEAD).g$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd $_pkgname
+ export SHELL_COMPLETIONS_DIR="$PWD/completions"
+ cargo build --release --locked
+}
+
+check() {
+ cd $_pkgname
+ cargo test --release --locked
+}
+
+package() {
+ cd "$srcdir/$_pkgname"
+ install -Dm755 target/release/$_pkgname "$pkgdir/usr/bin/$_pkgname"
+}
+