summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNafis2020-07-07 19:02:26 +0600
committerNafis2020-07-07 19:13:40 +0600
commit23a7f9bd89b4cf8a218f0effbb15cb671a193ffb (patch)
tree8d616597b5b34d4f11e9b05e6df780b97508fb4b
downloadaur-23a7f9bd89b4cf8a218f0effbb15cb671a193ffb.tar.gz
Initial commit
-rw-r--r--.SRCINFO33
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD58
-rw-r--r--gnome-flashback.pam6
4 files changed, 102 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7b9924eba4b3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,33 @@
+pkgbase = gnome-flashback-compiz
+ pkgdesc = GNOME Flashback session (with compiz support)
+ pkgver = 3.36.3
+ pkgrel = 3
+ url = https://wiki.gnome.org/Projects/GnomeFlashback
+ arch = x86_64
+ license = GPL
+ makedepends = autoconf-archive
+ makedepends = git
+ makedepends = intltool
+ makedepends = python
+ depends = gnome-bluetooth
+ depends = gnome-panel
+ depends = gnome-session
+ depends = gnome-settings-daemon
+ depends = gnome-themes-extra
+ depends = libibus
+ depends = metacity
+ depends = compiz>=0.9
+ optdepends = gnome-backgrounds: Default background
+ optdepends = gnome-control-center: System settings
+ optdepends = network-manager-applet: Network management
+ provides = gnome-flashback
+ conflicts = gnome-flashback
+ source = git+https://gitlab.gnome.org/GNOME/gnome-flashback.git#commit=5036ec999d9f9ad8772e863e4cee2b679beb569f
+ source = git+https://gitlab.gnome.org/GNOME/libgnome-volume-control.git
+ source = gnome-flashback.pam
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = 7148b3b1773fa312d6cd14798338cc70cffb6df7504ff1787687edd0363138d2
+
+pkgname = gnome-flashback-compiz
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..2d399546fdfc
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
+!gnome-flashback.pam
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..51b41a9580aa
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,58 @@
+# Maintainer: Nafis <mnabid.25@outlook.com>
+
+pkgname=gnome-flashback-compiz
+_pkgname=${pkgname%-compiz}
+pkgver=3.36.3
+pkgrel=3
+pkgdesc="GNOME Flashback session (with compiz support)"
+arch=('x86_64')
+url="https://wiki.gnome.org/Projects/GnomeFlashback"
+license=('GPL')
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+depends=('gnome-bluetooth' 'gnome-panel' 'gnome-session' 'gnome-settings-daemon' 'gnome-themes-extra' 'libibus' 'metacity' 'compiz>=0.9')
+makedepends=('autoconf-archive' 'git' 'intltool' 'python')
+optdepends=('gnome-backgrounds: Default background'
+ 'gnome-control-center: System settings'
+ 'network-manager-applet: Network management')
+_commit=5036ec999d9f9ad8772e863e4cee2b679beb569f # tags/3.36.3^0
+source=("git+https://gitlab.gnome.org/GNOME/gnome-flashback.git#commit=$_commit"
+ "git+https://gitlab.gnome.org/GNOME/libgnome-volume-control.git"
+ gnome-flashback.pam)
+sha256sums=('SKIP'
+ 'SKIP'
+ '7148b3b1773fa312d6cd14798338cc70cffb6df7504ff1787687edd0363138d2')
+
+pkgver() {
+ cd $_pkgname
+ git describe --tags | sed 's/-/+/g'
+}
+
+prepare() {
+ cd $_pkgname
+ git submodule init
+ git submodule set-url gvc/gvc "$srcdir/libgnome-volume-control"
+ git submodule update
+
+ NOCONFIGURE=1 ./autogen.sh
+}
+
+build() {
+ cd $_pkgname
+ ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --libexecdir=/usr/lib/$_pkgname \
+ --with-compiz-session --disable-schemas-compile --enable-compile-warnings=minimum
+ make
+}
+
+check() {
+ cd $_pkgname
+ make check
+}
+
+package() {
+ cd $_pkgname
+ make DESTDIR="$pkgdir" install
+
+ # Install pam file for the screensaver
+ install -Dm644 ../gnome-flashback.pam "$pkgdir/etc/pam.d/gnome-flashback"
+}
diff --git a/gnome-flashback.pam b/gnome-flashback.pam
new file mode 100644
index 000000000000..ebbb51dd0e82
--- /dev/null
+++ b/gnome-flashback.pam
@@ -0,0 +1,6 @@
+#%PAM-1.0
+auth include system-auth
+auth optional pam_gnome_keyring.so
+account include system-auth
+password include system-auth
+session include system-auth