summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2020-12-30 10:44:13 -0700
committerMark Wagie2020-12-30 10:44:13 -0700
commit1ee597346977befe4d55401edb101cd20d5fab97 (patch)
treec77113d58cab2add080372c26a1a4f61e80d9aab
downloadaur-1ee597346977befe4d55401edb101cd20d5fab97.tar.gz
initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD29
3 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2022c6df8493
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = gnome-fuzzy-app-search-git
+ pkgdesc = Fuzzy application search results for Gnome Search
+ pkgver = 2.r3.ga682991
+ pkgrel = 1
+ url = https://gitlab.com/Czarlie/gnome-fuzzy-app-search
+ arch = any
+ license = unknown
+ makedepends = git
+ depends = gnome-shell
+ provides = gnome-fuzzy-app-search
+ conflicts = gnome-fuzzy-app-search
+ source = git+https://gitlab.com/Czarlie/gnome-fuzzy-app-search.git
+ sha256sums = SKIP
+
+pkgname = gnome-fuzzy-app-search-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..4dab8d6386e3
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+# Ignore everything
+*
+
+# But not these files...
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5b4db1bef961
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
+pkgname=gnome-fuzzy-app-search-git
+pkgver=2.r3.ga682991
+pkgrel=1
+pkgdesc="Fuzzy application search results for Gnome Search"
+arch=('any')
+url="https://gitlab.com/Czarlie/gnome-fuzzy-app-search"
+license=('unknown')
+depends=('gnome-shell')
+makedepends=('git')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=('git+https://gitlab.com/Czarlie/gnome-fuzzy-app-search.git')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$srcdir/${pkgname%-git}"
+ make build
+}
+
+package() {
+ cd "$srcdir/${pkgname%-git}"
+ make INSTALL_PATH="$pkgdir/usr/share/gnome-shell/extensions" install
+}