summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEric Anderson2020-05-08 20:55:13 -0700
committerEric Anderson2020-05-08 20:55:13 -0700
commit432215754ba934473f7d459023a807e49d5070b2 (patch)
tree816320d5514f9486658e0e0886315c2b67bed448
parentfc54ceda2f91f09b45a83cc741dd389f1973c6c1 (diff)
downloadaur-432215754ba934473f7d459023a807e49d5070b2.tar.gz
Enable desmume as a desmume2015 alternative
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD9
2 files changed, 9 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e1c2e58a30fa..5e08aea0c246 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,14 @@
pkgbase = gnome-games-libretro
pkgdesc = Libretro definitions for gnome-games
pkgver = 3.36.0
- pkgrel = 1
+ pkgrel = 2
url = https://wiki.gnome.org/Apps/Games
arch = any
license = GPL3
makedepends = git
optdepends = libretro-blastem: Sega Mega Drive support
optdepends = libretro-bsnes-mercury-git: Super Nintendo Entertainment System support
+ optdepends = libretro-desmume: Nintendo DS support
optdepends = libretro-dosbox-git: MS-DOS support
optdepends = libretro-gambatte: Nintendo Game Boy/Game Boy Color support
optdepends = libretro-handy-git: Atari Lynx support
diff --git a/PKGBUILD b/PKGBUILD
index f7140683c676..77ae3d8d157a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=gnome-games-libretro
_srcname=gnome-games
pkgver=3.36.0
-pkgrel=1
+pkgrel=2
pkgdesc='Libretro definitions for gnome-games'
arch=('any')
url='https://wiki.gnome.org/Apps/Games'
@@ -11,8 +11,8 @@ license=('GPL3')
makedepends=('git')
optdepends=('libretro-blastem: Sega Mega Drive support'
'libretro-bsnes-mercury-git: Super Nintendo Entertainment System support'
- # TODO: see if renaming module to desmume works
#'libretro-desmume2015: Nintendo DS support'
+ 'libretro-desmume: Nintendo DS support'
'libretro-dosbox-git: MS-DOS support'
'libretro-gambatte: Nintendo Game Boy/Game Boy Color support'
'libretro-handy-git: Atari Lynx support'
@@ -39,4 +39,9 @@ package() {
cd "$_srcname"
install -d "$pkgdir"/usr/lib/libretro/
install -t "$pkgdir"/usr/lib/libretro/ flatpak/libretro-cores/*.libretro
+
+ cp "$pkgdir"/usr/lib/libretro/desmume2015.libretro \
+ "$pkgdir"/usr/lib/libretro/desmume.libretro
+ sed -i 's/DeSmuME 2015/DeSmuME/;s/desmume2015/desmume/' \
+ "$pkgdir"/usr/lib/libretro/desmume.libretro
}