summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEric Anderson2020-05-08 08:33:01 -0700
committerEric Anderson2020-05-08 08:33:01 -0700
commit818e717097fbcf7162be3ac0308c40c25502af63 (patch)
tree6016148ddd8bb0cdb1716e8a266ce90aa7893516
parentc9100939ed8ee83fce50564c3490da8bbd468f15 (diff)
downloadaur-818e717097fbcf7162be3ac0308c40c25502af63.tar.gz
Update deps based on changing packages available
bsnes is now very broken with graphical issues and constant crashes.
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD14
2 files changed, 5 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f7f7e68617d4..2373606e788e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -7,17 +7,15 @@ pkgbase = gnome-games-libretro
license = GPL3
makedepends = git
optdepends = libretro-blastem: Sega Mega Drive support
- optdepends = libretro-bsnes: Super Nintendo Entertainment System support
- optdepends = libretro-bsnes-mercury-git: Alternative Super Nintendo Entertainment System support
+ optdepends = libretro-bsnes-mercury-git: Super Nintendo Entertainment System support
optdepends = libretro-dosbox-git: MS-DOS support
optdepends = libretro-gambatte: Nintendo Game Boy/Game Boy Color support
optdepends = libretro-handy-git: Atari Lynx support
optdepends = libretro-mame-git: Arcade support
- optdepends = libretro-mednafen-saturn-git: Sega Saturn support
optdepends = libretro-mgba: Nintendo Game Boy Advance support
optdepends = libretro-nestopia: Nintendo Entertainment System support
optdepends = libretro-pcsx-rearmed-git: Sony PlayStation support
- optdepends = libretro-picodrive-git: Sega Genesis/Master System/CD/32X/Pico support
+ optdepends = libretro-picodrive: Sega Genesis/Master System/CD/32X/Pico support
optdepends = libretro-prosystem-git: Atari 7800 support
optdepends = libretro-stella2014-git: Atari 2600 support
source = git+https://gitlab.gnome.org/GNOME/gnome-games.git#tag=3.34.0
diff --git a/PKGBUILD b/PKGBUILD
index 732243fa2b5d..b716867e695d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,8 +10,7 @@ url='https://wiki.gnome.org/Apps/Games'
license=('GPL3')
makedepends=('git')
optdepends=('libretro-blastem: Sega Mega Drive support'
- 'libretro-bsnes: Super Nintendo Entertainment System support'
- 'libretro-bsnes-mercury-git: Alternative Super Nintendo Entertainment System support'
+ 'libretro-bsnes-mercury-git: Super Nintendo Entertainment System support'
# TODO: see if renaming module to desmume works
#'libretro-desmume2015: Nintendo DS support'
'libretro-dosbox-git: MS-DOS support'
@@ -21,13 +20,13 @@ optdepends=('libretro-blastem: Sega Mega Drive support'
# TODO: see if renaming module to beetle works
#'libretro-mednafen-ngp: Neo Geo Pocket Color'
#'libretro-mednafen-pce-fast: TurboGrafx support'
- 'libretro-mednafen-saturn-git: Sega Saturn support'
+ #'libretro-mednafen-saturn-git: Sega Saturn support'
#'libretro-mednafen-vb: Nintendo Virtual Boy support'
#'libretro-mednafen-wswan: WonderSwan support'
'libretro-mgba: Nintendo Game Boy Advance support'
'libretro-nestopia: Nintendo Entertainment System support'
'libretro-pcsx-rearmed-git: Sony PlayStation support'
- 'libretro-picodrive-git: Sega Genesis/Master System/CD/32X/Pico support'
+ 'libretro-picodrive: Sega Genesis/Master System/CD/32X/Pico support'
# Missing package
#'libretro-prboom: Doom support'
'libretro-prosystem-git: Atari 7800 support'
@@ -40,11 +39,4 @@ package() {
cd "$_srcname"
install -d "$pkgdir"/usr/lib/libretro/
install -t "$pkgdir"/usr/lib/libretro/ flatpak/libretro-cores/*.libretro
-
- # bsnes-mercury is available on the AUR, but doesn't build at the moment.
- # In general it's nice to provide the standard package as an option.
- cp "$pkgdir"/usr/lib/libretro/bsnes_mercury_balanced.libretro \
- "$pkgdir"/usr/lib/libretro/bsnes_balanced.libretro
- sed -i 's/bsnes-mercury/bsnes/;s/bsnes_mercury/bsnes/' \
- "$pkgdir"/usr/lib/libretro/bsnes_balanced.libretro
}