summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormax.bra2015-06-08 12:13:01 +0200
committermax.bra2015-06-08 12:13:01 +0200
commitba5b0272cec4aea05d0a5ced0766062c7e07262d (patch)
treed4e97595bea7bdd666630423138f70b3a8183bc1
downloadaur-ba5b0272cec4aea05d0a5ced0766062c7e07262d.tar.gz
Initial import
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD28
-rw-r--r--gnome-gmail.install16
3 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e0ed5438530c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = gnome-gmail
+ pkgdesc = It allows desktop mail actions, such as 'Send File as Email' or web 'mailto' links, to be handled by the Gmail web client.
+ pkgver = 1.9.1.1
+ pkgrel = 1
+ url = https://davesteele.github.io/gnome-gmail/index.html
+ install = gnome-gmail.install
+ arch = any
+ license = GPL2
+ makedepends = python2-distutils-extra
+ depends = python2-gobject
+ depends = python2-gnomekeyring
+ depends = desktop-file-utils
+ depends = python2-setuptools
+ depends = python2-xdg
+ depends = gtk3>=3.10
+ optdepends = nautilus-sendto: automatically upload an email with a file attachment from nautilus
+ source = https://github.com/max72bra/gnome-gmail/archive/master/1.9.1.1.tar.gz
+ md5sums = 2954d7f5a13f396c459054b6246193df
+
+pkgname = gnome-gmail
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7c299bb04537
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Contributor: Roberto Nobrega <rwnobrega@gmail.com>
+# Contributor: max.bra <max dot bra at alice dot it>
+
+pkgname=gnome-gmail
+pkgver=1.9.1.1
+_pkgbranch=master
+pkgrel=1
+pkgdesc="It allows desktop mail actions, such as 'Send File as Email' or web 'mailto' links, to be handled by the Gmail web client."
+arch=('any')
+url="https://davesteele.github.io/gnome-gmail/index.html"
+license=('GPL2')
+depends=('python2-gobject' 'python2-gnomekeyring' 'desktop-file-utils' 'python2-setuptools' 'python2-xdg' 'gtk3>=3.10')
+optdepends=('nautilus-sendto: automatically upload an email with a file attachment from nautilus')
+makedepends=('python2-distutils-extra')
+source=('https://github.com/max72bra/gnome-gmail/archive/master/1.9.1.1.tar.gz')
+md5sums=('2954d7f5a13f396c459054b6246193df')
+install=$pkgname.install
+
+build() {
+ cd "$srcdir"/$pkgname-$_pkgbranch-$pkgver
+ python2 ./setup.py build
+}
+
+package() {
+ cd "$srcdir"/$pkgname-$_pkgbranch-$pkgver
+ python2 ./setup.py install --root="$pkgdir"
+}
+
diff --git a/gnome-gmail.install b/gnome-gmail.install
new file mode 100644
index 000000000000..5c1bce5009b0
--- /dev/null
+++ b/gnome-gmail.install
@@ -0,0 +1,16 @@
+post_install() {
+ cat <<- EOF
+ ==> Restart Gnome session.
+ ==> Available config at ~/.config/gnome-gmail/gnome-gmail.conf.
+EOF
+ update-desktop-database -q
+}
+
+post_remove() {
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install $1
+}
+