summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormax.bra2016-08-13 18:20:07 +0200
committermax.bra2016-08-13 18:20:07 +0200
commite7b21dd133314e40697be257f227b76761081191 (patch)
treee2cec91263f6ab4a9bacc033e0d52543e0fd6546
parentf67f12ffbb3b51d14f5b37768b3077b96b4eae6d (diff)
downloadaur-e7b21dd133314e40697be257f227b76761081191.tar.gz
patch for bug 29 until official release
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD14
2 files changed, 14 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0a8d0dd43a14..3671dc831de9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = gnome-gmail
pkgdesc = It allows desktop mail actions, such as 'Send File as Email' or web 'mailto' links, to be handled by the Gmail web client.
pkgver = 2.2
- pkgrel = 1
+ pkgrel = 2
url = https://davesteele.github.io/gnome-gmail/index.html
install = gnome-gmail.install
arch = any
@@ -16,7 +16,9 @@ pkgbase = gnome-gmail
depends = libwnck3
optdepends = nautilus-sendto: automatically upload an email with a file attachment from nautilus
source = https://github.com/davesteele/gnome-gmail/archive/master/2.2.tar.gz
+ source = https://github.com/davesteele/gnome-gmail/commit/802e59543229359b3f383ccd6b31951280a4d992.diff
md5sums = 3a5b983c75eff3f5ce638aba28b2694f
+ md5sums = 79df46e65a83869f28a08aa8894699ef
pkgname = gnome-gmail
diff --git a/PKGBUILD b/PKGBUILD
index dfa88ee4a03a..72c8fc5caab4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=gnome-gmail
pkgver=2.2
_pkgbranch=master
-pkgrel=1
+pkgrel=2
pkgdesc="It allows desktop mail actions, such as 'Send File as Email' or web 'mailto' links, to be handled by the Gmail web client."
arch=('any')
url="https://davesteele.github.io/gnome-gmail/index.html"
@@ -12,10 +12,18 @@ license=('GPL2')
depends=('python-gobject' 'python2-gnomekeyring' 'desktop-file-utils' 'python-setuptools' 'python-xdg' 'python-six' 'libwnck3')
optdepends=('nautilus-sendto: automatically upload an email with a file attachment from nautilus')
makedepends=('python-distutils-extra')
-source=(https://github.com/davesteele/gnome-gmail/archive/master/$pkgver.tar.gz)
-md5sums=('3a5b983c75eff3f5ce638aba28b2694f')
+source=(https://github.com/davesteele/gnome-gmail/archive/master/$pkgver.tar.gz
+ https://github.com/davesteele/gnome-gmail/commit/802e59543229359b3f383ccd6b31951280a4d992.diff)
+md5sums=('3a5b983c75eff3f5ce638aba28b2694f'
+ '79df46e65a83869f28a08aa8894699ef')
install=$pkgname.install
+prepare() {
+ cd "$srcdir"/$pkgname-$_pkgbranch-$pkgver
+ # patch for bug 29 until official release
+ patch -p1 < ../802e59543229359b3f383ccd6b31951280a4d992.diff
+}
+
build() {
cd "$srcdir"/$pkgname-$_pkgbranch-$pkgver
/usr/bin/python ./setup.py build