summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRafael Fontenelle2018-12-30 10:13:17 -0200
committerRafael Fontenelle2018-12-30 10:13:17 -0200
commitc7a1ed3e509d0940b1aee9e5e51dc0e7a1af3478 (patch)
tree93db5a42f5a791c64fe57ff7000d55fcc733deab
parent00e873e5ace1b43a7b83338d6ad88651a6c5ad9a (diff)
downloadaur-c7a1ed3e509d0940b1aee9e5e51dc0e7a1af3478.tar.gz
Update to 1.5.0
It was necessary to disable pkg-config checking for gst-plugins-good because gst-plugins-good package doesn't provide a .pc file. gtk-doc and yelp-tools in makedepends were also necessary, even though no doc is enabled, as build was failing.
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD17
2 files changed, 19 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c80f76e47723..dc4b0b686367 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,21 @@
pkgbase = gnome-internet-radio-locator
pkgdesc = Easily find live radio programs based on geographical location of radio broadcasters on the Internet
- pkgver = 1.4.0
+ pkgver = 1.5.0
pkgrel = 1
- url = https://wiki.gnome.org/Apps/Girl
+ url = https://wiki.gnome.org/Apps/InternetRadioLocator
arch = x86_64
license = GPL
makedepends = intltool
makedepends = itstool
makedepends = python
+ makedepends = gtk-doc
+ makedepends = yelp-tools
depends = libchamplain
depends = geocode-glib
depends = gst-plugins-bad
- source = https://download.gnome.org/sources/gnome-internet-radio-locator/1.4/gnome-internet-radio-locator-1.4.0.tar.xz
- sha256sums = 12859a60086dedcfd9a49e3f5f947e11394ddbfe914a4ee8cc0a86492b4e46e7
+ depends = gst-plugins-good
+ source = https://download.gnome.org/sources/gnome-internet-radio-locator/1.5/gnome-internet-radio-locator-1.5.0.tar.xz
+ sha256sums = fd6ce280afc89cfad3ed864f90c3dd8892b9c75811b7805cbc3dbacf78d78524
pkgname = gnome-internet-radio-locator
diff --git a/PKGBUILD b/PKGBUILD
index c299743cfd7a..4e82776cd4d2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,16 +2,23 @@
# Contributor: Balló György <ballogyor+arch at gmail dot com>
pkgname=gnome-internet-radio-locator
-pkgver=1.4.0
+pkgver=1.5.0
pkgrel=1
pkgdesc="Easily find live radio programs based on geographical location of radio broadcasters on the Internet"
arch=('x86_64')
-url="https://wiki.gnome.org/Apps/Girl"
+url="https://wiki.gnome.org/Apps/InternetRadioLocator"
license=(GPL)
-depends=('libchamplain' 'geocode-glib' 'gst-plugins-bad')
-makedepends=('intltool' 'itstool' 'python')
+depends=('libchamplain' 'geocode-glib' 'gst-plugins-bad' 'gst-plugins-good')
+makedepends=('intltool' 'itstool' 'python' 'gtk-doc' 'yelp-tools')
source=(https://download.gnome.org/sources/$pkgname/${pkgver%.*}/$pkgname-$pkgver.tar.xz)
-sha256sums=('12859a60086dedcfd9a49e3f5f947e11394ddbfe914a4ee8cc0a86492b4e46e7')
+sha256sums=('fd6ce280afc89cfad3ed864f90c3dd8892b9c75811b7805cbc3dbacf78d78524')
+
+prepare() {
+ cd $pkgname-$pkgver
+ # disable pkgconfig for gst-plugins-good, as it currently doesn't have .pc file
+ sed -i '/gstreamer-plugins-good-1.0 \\/d' configure.ac
+ autoreconf
+}
build() {
cd $pkgname-$pkgver