summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKevin Majewski2020-02-22 18:48:41 +0100
committerKevin Majewski2020-02-22 18:48:41 +0100
commit6ca32ff628f693f43b6ca6cfd30f417500a43689 (patch)
tree5e552f4b5452a4d98435638bf4d449e9697c52f4
downloadaur-6ca32ff628f693f43b6ca6cfd30f417500a43689.tar.gz
Initial commit
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD54
-rw-r--r--add-cinnamon.diff44
-rw-r--r--gnome-keyring.install7
4 files changed, 133 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..550233eda1d0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+pkgbase = gnome-keyring-git
+ pkgdesc = Stores passwords and encryption keys
+ pkgver = 3.35.1+8+gfd130b33
+ pkgrel = 1
+ epoch = 1
+ url = https://wiki.gnome.org/Projects/GnomeKeyring
+ install = gnome-keyring.install
+ arch = x86_64
+ groups = gnome
+ license = GPL
+ license = LGPL
+ makedepends = git
+ makedepends = docbook-xsl
+ makedepends = python
+ depends = gcr
+ depends = libcap-ng
+ depends = pam
+ depends = openssh
+ provides = gnome-keyring
+ provides = org.freedesktop.secrets
+ conflicts = gnome-keyring
+ source = git+https://gitlab.gnome.org/GNOME/gnome-keyring.git
+ source = add-cinnamon.diff
+ sha256sums = SKIP
+ sha256sums = d05210f5b0a7d4b22c0dff2854854af2eb5708aa2b296095e070dca68e9f815a
+
+pkgname = gnome-keyring-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2b445a0b7046
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,54 @@
+pkgname=gnome-keyring-git
+_pkgname=gnome-keyring
+pkgver=3.35.1+8+gfd130b33
+pkgrel=1
+epoch=1
+pkgdesc="Stores passwords and encryption keys"
+url="https://wiki.gnome.org/Projects/GnomeKeyring"
+arch=(x86_64)
+license=(GPL LGPL)
+depends=('gcr' 'libcap-ng' 'pam' 'openssh')
+makedepends=('git' 'docbook-xsl' 'python')
+provides=('gnome-keyring' 'org.freedesktop.secrets')
+conflicts=('gnome-keyring')
+groups=('gnome')
+install=gnome-keyring.install
+source=("git+https://gitlab.gnome.org/GNOME/gnome-keyring.git"
+ add-cinnamon.diff)
+sha256sums=('SKIP'
+ 'd05210f5b0a7d4b22c0dff2854854af2eb5708aa2b296095e070dca68e9f815a')
+
+pkgver() {
+ cd $_pkgname
+ git describe --tags | sed 's/-/+/g'
+}
+
+prepare() {
+ cd $_pkgname
+ git apply -3 ../add-cinnamon.diff
+ NOCONFIGURE=1 ./autogen.sh
+}
+
+build() {
+ cd $_pkgname
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --libexecdir=/usr/lib \
+ --with-pam-dir=/usr/lib/security \
+ --disable-static \
+ --disable-schemas-compile
+ sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
+ make
+}
+
+check() {
+ cd $_pkgname
+ # Secure memory tests fail
+ dbus-run-session make -k check || :
+}
+
+package() {
+ cd $_pkgname
+ make DESTDIR="$pkgdir" install
+}
diff --git a/add-cinnamon.diff b/add-cinnamon.diff
new file mode 100644
index 000000000000..51fe45b0c0ce
--- /dev/null
+++ b/add-cinnamon.diff
@@ -0,0 +1,44 @@
+ daemon/gnome-keyring-pkcs11.desktop.in.in | 2 +-
+ daemon/gnome-keyring-secrets.desktop.in.in | 2 +-
+ daemon/gnome-keyring-ssh.desktop.in.in | 2 +-
+ 3 files changed, 3 insertions(+), 3 deletions(-)
+
+diff --git c/daemon/gnome-keyring-pkcs11.desktop.in.in i/daemon/gnome-keyring-pkcs11.desktop.in.in
+index b43e1e9d..80434cbd 100644
+--- c/daemon/gnome-keyring-pkcs11.desktop.in.in
++++ i/daemon/gnome-keyring-pkcs11.desktop.in.in
+@@ -3,7 +3,7 @@ Type=Application
+ Name=Certificate and Key Storage
+ Comment=GNOME Keyring: PKCS#11 Component
+ Exec=@bindir@/gnome-keyring-daemon --start --components=pkcs11
+-OnlyShowIn=GNOME;Unity;MATE;
++OnlyShowIn=GNOME;Unity;MATE;Cinnamon;
+ NoDisplay=true
+ X-GNOME-Autostart-Phase=PreDisplayServer
+ X-GNOME-AutoRestart=false
+diff --git c/daemon/gnome-keyring-secrets.desktop.in.in i/daemon/gnome-keyring-secrets.desktop.in.in
+index dd9deec7..b6d7b2d0 100644
+--- c/daemon/gnome-keyring-secrets.desktop.in.in
++++ i/daemon/gnome-keyring-secrets.desktop.in.in
+@@ -3,7 +3,7 @@ Type=Application
+ Name=Secret Storage Service
+ Comment=GNOME Keyring: Secret Service
+ Exec=@bindir@/gnome-keyring-daemon --start --components=secrets
+-OnlyShowIn=GNOME;Unity;MATE;
++OnlyShowIn=GNOME;Unity;MATE;Cinnamon;
+ NoDisplay=true
+ X-GNOME-Autostart-Phase=PreDisplayServer
+ X-GNOME-AutoRestart=false
+diff --git c/daemon/gnome-keyring-ssh.desktop.in.in i/daemon/gnome-keyring-ssh.desktop.in.in
+index 38aa24cb..163ff554 100644
+--- c/daemon/gnome-keyring-ssh.desktop.in.in
++++ i/daemon/gnome-keyring-ssh.desktop.in.in
+@@ -3,7 +3,7 @@ Type=Application
+ Name=SSH Key Agent
+ Comment=GNOME Keyring: SSH Agent
+ Exec=@bindir@/gnome-keyring-daemon --start --components=ssh
+-OnlyShowIn=GNOME;Unity;MATE;
++OnlyShowIn=GNOME;Unity;MATE;Cinnamon;
+ X-GNOME-Autostart-Phase=PreDisplayServer
+ X-GNOME-AutoRestart=false
+ X-GNOME-Autostart-Notify=true
diff --git a/gnome-keyring.install b/gnome-keyring.install
new file mode 100644
index 000000000000..2ed06c222e65
--- /dev/null
+++ b/gnome-keyring.install
@@ -0,0 +1,7 @@
+post_install() {
+ setcap cap_ipc_lock+ep usr/bin/gnome-keyring-daemon
+}
+
+post_upgrade() {
+ post_install
+}