summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Peukert2021-12-09 04:55:29 +0100
committerDaniel Peukert2021-12-09 04:55:29 +0100
commitca4f93bcef587966eb457c54bdd45b4b1fcbec69 (patch)
tree8470c65e663dbfb77a11f4c790e503a46a952011
parente2b039987184fea57acefe78d1d1473fd2b80022 (diff)
downloadaur-ca4f93bcef587966eb457c54bdd45b4b1fcbec69.tar.gz
Remove python2 support from gnome-keyring-import-export
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD16
2 files changed, 8 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9632881f8e13..5390fcdb3f73 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,16 @@
pkgbase = gnome-keyring-import-export-git
- pkgdesc = Simple script for exporting gnome2 (seahorse) keyrings, and re-importing on another machine - git version
+ pkgdesc = Simple script for exporting Gnome/Seahorse keyrings, and re-importing on another machine - git version
pkgver = r20.g6b55065
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/spookylukey/gnome-keyring-import-export
arch = any
license = unknown
makedepends = git
depends = python
depends = python-secretstorage
- depends = pygtk
- depends = python2
- depends = python2-gnomekeyring
- depends = python2-lxml
provides = gnome-keyring-import-export
conflicts = gnome-keyring-import-export
source = gnome-keyring-import-export-git::git+https://github.com/spookylukey/gnome-keyring-import-export
- sha256sums = SKIP
+ sha512sums = SKIP
pkgname = gnome-keyring-import-export-git
diff --git a/PKGBUILD b/PKGBUILD
index a29e957da5b2..91ce917cabba 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,18 @@
-# Maintainer: Daniel Peukert <dan.peukert@gmail.com>
+# Maintainer: Daniel Peukert <daniel@peukert.cc>
_pkgname='gnome-keyring-import-export'
pkgname="$_pkgname-git"
pkgver='r20.g6b55065'
-pkgrel='1'
-pkgdesc='Simple script for exporting gnome2 (seahorse) keyrings, and re-importing on another machine - git version'
+pkgrel='2'
+pkgdesc='Simple script for exporting Gnome/Seahorse keyrings, and re-importing on another machine - git version'
arch=('any')
url="https://github.com/spookylukey/$_pkgname"
license=('unknown')
-depends=(
- # secret_storage_import_export.py
- 'python' 'python-secretstorage'
- # gnome_keyring_import_export.py
- 'pygtk' 'python2' 'python2-gnomekeyring' 'python2-lxml'
-)
+depends=('python' 'python-secretstorage')
makedepends=('git')
provides=("$_pkgname")
conflicts=("$_pkgname")
source=("$pkgname::git+$url")
-sha256sums=('SKIP')
+sha512sums=('SKIP')
_sourcedirectory="$pkgname"
@@ -29,5 +24,4 @@ pkgver() {
package() {
cd "$srcdir/$_sourcedirectory/"
install -Dm755 'secret_storage_import_export.py' "$pkgdir/usr/bin/secret-storage-import-export"
- install -Dm755 'gnome_keyring_import_export.py' "$pkgdir/usr/bin/$_pkgname"
}